My site does not show https status

Hello everyone,
I have configure my website in cloudflare. My hosting is infinityfree.I have set SSL/TLS encryption mode is Flexible & Always Use HTTPS is ON, HTTP Strict Transport Security (HSTS) not enable. But now my site does not load in https status. Can you please tell me how can i enable https in my website and run successfully. My Domain is http://imtiaz.me

You may have http contents in your website. So your site may not show fully secure. Change the ssl mode to Strict.

Hi @mdiatopu, you have a bit of mixed content on the site with a script, note shield in right side of address bar.

Mixed content errors mean that your website is being loaded over HTTPS but some of the resources are being loaded over HTTP. To fix this you will need to edit your source code and change all resources to load over a relative path, or directly over HTTPS.

For example, if you load your images with a full URL:

<img src="http://example.com/image.jpg" />

You would want to change this to:

<img src="//example.com/image.jpg" />

By removing the http:, the browser will use whichever protocol the visitor is already using. An alternative option would be to enable the Automatic HTTPS Rewrites feature that can potentially fix these errors for you automatically. Do be aware that resources loaded by JavaScript or CSS will not be automatically rewritten and mixed content warnings will still appear.

See this Community Tip for further details

This topic was automatically closed after 30 days. New replies are no longer allowed.