My registar for my domaine is cloudflare but

Hello and sorry for my bad english,

My registar for my domain name is cloudflare and my server (vps) is at ionos.

Here I am trying to configure my domain name on my server (vps) but I cannot. I repeat that my domain name is with cloudflare and not with ionos!

So how do I link my domain name to my server (vps)

Your VPS server hostname should contain your main domain name and your reverse (PTR) record should also return your main domain name.

But, having in mind, if the records would be proxied via Cloudflare :orange: cloud, then I think if you do not access directly by IP address, I expect you would get some errors (if using Free plan, which does not cover ports like for example SSH, FTP, etc. to be passed through the Cloudflare - for which you have to use Cloudflare Spectrum at least on my first sight).

Do you know how to configure a hostname at your VPS?

Hi thank you again for answering me,


They gave me a cname, A and a txt ton configure on the dns of cloudflare

From the screenshot above, well, may I ask who is your hosting/server provider?

If you have the IP address for your VPS server, then at the Cloudflare DNS tab/settings page you would need to add an record A otokonovel.com with content value of your IP address and make it :grey: if you want to use it as a hostname, while if you want your web traffic to be passed throught the Cloudflare, then switch to :orange: (but to all your services you would need to access directly via IP address).

Do you have an A record at Cloudflare dashboard for your domain?

The same goes for e-mail.
Also, if not having the MX record(s) otokonovel.com with the same value as provided in the above screenshot to make sure your e-mail are going to work.

Should look like similart to this one:

Hello again my hosoting name is ionos
Yes i have the adress ip, The thing is what I did but when I go on the link of my site it puts me like what it is offline or that we change anything.

When I visit it via Web browser, I got redirected from /wp-admin/install.php with a 401 authorization page - that is the expected behaviour, right?

Regarding HTTP, kindly see the options from below article how to setup an SSL for your site:

Ys normaly is what i need to have but i have this error :“ERR_QUIC_PROTOCOL_ERROR” fo

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.