My IPv6 address keeps changing and making whitelisting impossible in firewall rules


I enabled “IPv6 Compatibility” on my website and it works well. I see some IP’s that come to my website in IPv6 instead of IPv4 and some are in IPv4. However, there is a couple of problems.

Firewall Rules
I use the firewall rules to filter and block out IP’s, ASN URL Paths and such. The problem is one of the firewall rules I use is to add Challenge Captcha on the site URL path to wp-login.php
It’s very effective against bots but this also means I see the Challenge Captcha too. (I’m tired of pointing out boats and sidewalks) LMAO

Before I enabled “IPv6 Compatibility”, I added my IPv4 address to Tools and Whitelisted the IP. It worked well. I never saw the Captcha page again. Now that I added “IPv6 Compatibility” to my website, My IPv4 doesn’t work and I now need to whitelist my IPv6 address to make the Captcha disappear.

The problem with this is it seems my IPv6 address changes every day. So I’m always constantly whitelisting it. It’s getting annoying quickly. Since mine changes, wouldn’t others as well change and then IP block be completely useless if I block those users for reasons?
I’m just wondering if I should just keep “IPv6 Compatibility” turned off.

I want to point out that, I’m using NameHero and Cloudflare in cPanel. This is where I have “IPv6 Compatibility” turned on. But it’s turned off in Network on Cloudflare. My Domain DNS is pointed at Cloudflare then to the server.

I hope there is a simple fix then just turn off IPv6 Compatibility.

This topic was automatically closed after 30 days. New replies are no longer allowed.