My homepage content is not refreshing for visitors

My homepage content is not refeshing for visitors. I upgraded to Cloudflare Pro yesterday and this happened today.

We are a news website. So, it’s really affecting us.

May I ask if you’re using WordPress or some other CMS to manage your content? :thinking:

If so, are you using Cloudflare APO for WordPress too, or not?

May I ask you to post and share your domain name in bracketed dot [.] notation here with us so we could double-check, troubleshoot and provide some feedback information? :thinking:

Furthermore, may I ask you to check out what option have you got selected by navigating to the Cloudflare dashboard → Caching → Configuration → find section “Browser Cache TTL” and make sure the selected option from the dropdown menu is “Respect Existing Headers”.

On the same menu, click on the blue button saying “Purge Everything” to flush the cache at Cloudflare Edge, just in case.

Wait for a minute or two.

Refresh a page in your Web browser, otherwise try clearing your Web browser cache or use a different Web browser to test out again.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?


  1. Yes, i’m using wordpress.

  2. I’m using Cloudflare APO for WordPress.

  3. I can’t share my website link here. Cloudflare is not allowing me.

Browser cache is set to “Respect Existing Headers”.

When i purged everything, the content on homepage refreshed. I do this after i publish every content. Then it appears on homepage. If not, homepage won’t refresh.

I tried different browser and incognito mode. The issue persisted.


@gistreel I’ll DM you to get more info on this.