My email is down. Its suddenly telling me I


#1

Do not have an MX record, but i do. Please help. I had no problems with my setup for months until today.


#2

My bad. blacksun.tk is my domain


#3

Your website is not available and there are no DNS records for blacksun.tk: https://www.whatsmydns.net/#A/blacksun.tk

Perhaps your domain has expired?


#4

There are delegation records for blacksun.tk

$ dig ns blacksun.tk

; <<>> DiG 9.13.5 <<>> ns blacksun.tk
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 56110
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;blacksun.tk.                   IN      NS

;; ANSWER SECTION:
blacksun.tk.            86400   IN      NS      hope.ns.cloudflare.com.
blacksun.tk.            86400   IN      NS      terry.ns.cloudflare.com.

;; Query time: 188 msec
;; SERVER: 127.0.0.53#53(127.0.0.53)
;; WHEN: Wed Jan 09 02:01:12 IST 2019
;; MSG SIZE  rcvd: 96

So domain can’t be expired (and those are free domains anyway, do they really expire?)

Anyway the domain has A records as well on the NS above:

$ dig @hope.ns.cloudflare.com blacksun.tk

; <<>> DiG 9.13.5 <<>> @hope.ns.cloudflare.com blacksun.tk
; (2 servers found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40034
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;blacksun.tk.                   IN      A

;; ANSWER SECTION:
blacksun.tk.            300     IN      A       72.87.95.166

;; Query time: 74 msec
;; SERVER: 2400:cb00:2049:1::adf5:3aa3#53(2400:cb00:2049:1::adf5:3aa3)
;; WHEN: Wed Jan 09 02:03:02 IST 2019
;; MSG SIZE  rcvd: 56

In fact, the domain also has an MX record…

$ dig @hope.ns.cloudflare.com mx blacksun.tk

; <<>> DiG 9.13.5 <<>> @hope.ns.cloudflare.com mx blacksun.tk
; (2 servers found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34341
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 2
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;blacksun.tk.                   IN      MX

;; ANSWER SECTION:
blacksun.tk.            300     IN      MX      1 blacksun.tk.

;; ADDITIONAL SECTION:
blacksun.tk.            300     IN      A       72.87.95.166

;; Query time: 74 msec
;; SERVER: 2400:cb00:2049:1::adf5:3aa3#53(2400:cb00:2049:1::adf5:3aa3)
;; WHEN: Wed Jan 09 02:05:17 IST 2019
;; MSG SIZE  rcvd: 72

… and an SMTP server replies on port 25. But I didn’t know which user @ blacksun.tk to try to inject a message to, to test it.


#5

Sorry about that, it was probably a glitch on the www.whatsmydns.net service. When I first consulted it, it showed no records for your domain, no A, CNAME, MX etc. But now it is showing your domain DNS records just fine.

The only MX record says 1:blacksun.tk. is this the correct server for your mail provider? Since Cloudflare does not proxy mail, your best bet is to talk to your hosting/mail provider to see if any configuration was changed on their end that require you to update your DNS records.


#6

The SMTP server seems to run on Verizon FIOS service, i.e. probably he runs his own SMTP server.


#7

Hi guys sorry I was away a few days. Thanks for the help! I do run my own servers. It seems freenom completely deleted my registered domain for some reasonwith no warning, its free you get what you pay for I guess. But I reregistered it and all seems fine now. Thanks for your help!


closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.