My domains universal SSL Does not works

Hi, I get Error code 525 during waiting a few minutes after trying to reach my website. I disabled and enabled universal SSL but the problem appear again. At my hosting, support said to contact you.

Is your site loading over HTTPS when Cloudflare is paused?

1 Like

Yes, it i still trying to access with https, even I tried with developer mode too and tested open URL in incognito mode

Your answer is unclear. Is your site working properly with HTTPS while Cloudflare is paused?

1 Like

No, it does not works. Same problem appears when I disable cloudflare

Good. You are making progress toward getting your site working. Keep Cloudflare paused and work with your host to ensure that your site loads over HTTPS. Only then should you consider resuming the Cloudflare proxy.

If you need a certificate and cannot use an automated CA like Let’s Encrypt and don’t need a commercial certificate, you can always use a Cloudflare Origin CA certificate. It will present an Unknown Issuer warning when the Cloudflare proxy is off. It is trusted by the Cloudflare proxy, though, which means it is compatible with Full (Strict) mode.


I tried all ways but same problem, only change is in error code, it is showing 526 now. When I disabled cloudflare I can not access website too

You need to work with your hosting provider to get your site working over HTTPS without Cloudflare before you can expect it to work with Cloudflare. Your site will not work with Cloudflare until it works without Cloudflare. You must fix the underlying problem first.


My hosting support team wrote me that my website’s www. Version is connected to different ip as I set for version without www, it is redirected.
I tried to change cname and set ip but can not did it.

Please see test:

:~$ host has address has IPv6 address 2a01:54e0:fb00::301

So it should has following ip:

It looks like you have fixed it since your previous reply.

I do not know how, but anyway I can not say that problem solved, because it takes so long time during website loading. And at this moment problem starts again 525 error. Please could you check on which ip is going cname record?

I don’t know what that means. You do not have any visible CNAME records. Proxied :orange: CNAMEs are published as A and AAAA records using Cloudflare IPs. 285	IN	A 285	IN	A	285	IN	A	285	IN	A

Now all is working, could you provide solutions?

Again, I do not follow your request. You indicate that it is working. What additional solutions do you need?

If you are asking me for an explanation of what fixed it, you would need to tell me since you are the one who made whatever changes solved your problem.

I am glad you got your site working.

:slight_smile: it is funny, I do not know what action helped me.

1 Like

Any ways, website works like :rocket:, thanks


Today I discovered that the problem appeared again, without any changes and any touch. Please help

Your best option is to read through this topic again and repeat the troubleshooting steps.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.