My domain stops working anytime I change my dns to 'proxied'

I think this error is because I don’t have a cloudflare universal SSL certificate. Please how can I activate it back.

What’s the domain?


You have a DNSSEC issue. Either disable DNSSEC at your registrar or make sure it’s properly configured with the Cloudflare values.

I have removed my DNSSEC record now.
Please, what next?

What’s your encryption mode on Cloudflare?

I turned it off since this issue kept popping up.

Is there a particular settings that I should switch it to?

Make sure you select Full Strict.

But I noticed that my universal SSL is not active yet.

Also should I change it to proxied now?

Then you need to enable Universal SSL first.

I have enabled it

Any update?

Well, seems to work -

5 posts were split to a new topic: MX issues 2