My domain IP is not pointed correctly even after changing name servers


MY Domain IP is not configured properly even after making required changes.
My IP Is 160.153.137.170

I am getting in Godaddy console even after configuring DNS as
"
We need your help to finish connecting this domain to your site.

  1. Log in to your domain registrar and update the DNS A record to 160.153.137.170 .
  2. Come back here.
    "

The wired problem is my website is reachable at
www.synergy-tech.co.in/login
but not on
www.synergy-tech.co.in

Cloudflare Diagnostic Center: https://www.cloudflare.com/diagnostic-center/
Results are as follows:
Description

Check for redirect loops

has_redirect_loop

Yes, your request resulted in a redirect loop.

Check the HTTPS status

request_failed

Your request failed because the web server did not respond.

Check if redirecting unencrypted HTTP traffic works

request_failed

Your request failed because the web server did not respond.

What SSL encryption mode you are using? Flexible?

Yes its Flexible

That’s the root of the problem. Your server needs a TLS/SSL certificate to be secure. If your host won’t provide a certificate, but will let you install your own, Cloudflare can provide that:

2 Likes

I am using managed WordPress on godaddy. Can you guide?

Sorry, unless it’s cPanel as in the article I linked to, you’ll have to have godaddy assist with certificate installation. If that’s not an option, it’s best to set SSL Mode to Off, as that should get your site working again.

1 Like

I believe your website already has HTTPS previously, right?

Here’s what happened:

  1. Visitor visits your website in HTTPS.
  2. But your website is using Flexible SSL mode. So, Cloudflare will contact your origin server (or hosting provider) using HTTP (port 80).
  3. Your origin server sees the traffic coming from port 80, thus your origin server tries to redirect the user to HTTPS (but in fact the visitor is already visiting your site in HTTPS).
  4. Visitor receives the 301 redirect, then it tries to visit your site in HTTPS again, but Cloudflare still visits your site via HTTP. This causes redirect loop.

Try setting SSL mode to Full (strict). If you get Error 526, then consider installing SSL cert in GoDaddy side.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.