My domain cant not be found in nameserver

just as i said in the title, my domain is foolyou.top,
i have add a A cord to the root of foolyou.top, and the subdomain netdata.foolyou.top & one.foolyou.top
have cname cord to the root domain.
However, when i ping foolyou.top, it tell me that “ping: foolyou.top: Name or service not known”

When i try “nslookup foolyou.top”
it reports this:

;; Got SERVFAIL reply from 8.8.8.8, trying next server
;; Got SERVFAIL reply from 8.8.8.8, trying next server
Server: 1.1.1.1
Address: 1.1.1.1#53

** server can’t find foolyou.top: SERVFAIL

So, what can i do to resolve this problem ?

Is there someone could help me?
thank you

By the way, i have try to set the nameserver to 8.8.8.8

Hi @l1349422030, it does not look like you have a certificate on your origin server but ssl on your crypto tab is set to Full (Strict). The best bet is to get a certificate on the origin (you can do that self-signed for free from the crypto tab). A less desirable option to get things working quickly is to set ssl to flexible to see if the site loads.

It seems the domain has an incorrect DS record, so validating resolvers like 1.1.1.1 and 8.8.8.8 are unable to resolve it.

http://dnsviz.net/d/foolyou.top/XJUmVg/dnssec/

(Mouse over the long red line.)

The “2371 13 2” part is correct, but the digest is wrong. Go to the DNS section of Cloudflare’s dashboard, and the DS records section of NameSilo’s control panel, and try again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.