My DNS won't work

Hi there,

I don’t really have that much experience with DNS. I have set it up once before using bind on Ubuntu during my education but I have never used cloudflare or any other registrar before.
I bought my domain, veelaerthome.be, at one.com.
I then tried creating two subdomains, one for nextcloud and one for portainer, and pointed both A records to my public IP.
I then set up nginx proxy manager using docker and tried to create a proxy host for my 2 subdomains so they point to the correct service but this also didn’t want to work as I couldn’t create the ssl certificate and even with only http it didn’t work to resolve to either nextcloud.veelaerthome.be or portainer.veelaerthome.be.

I then imported my one.com domain into cloudflare so I could use a DNS challenge in the ssl creation. After imprting into cloudflare I did get the ssl certificate generated but still it won’t resolve.
I don’t really know what I am doing wrong as in my head it is not really a complicated setup that I am using and the records I created seem fairly normal but it still just won’t work.

Anyone have an idea? if required I can ofcourse provide screenshots of my setup so far :slight_smile:

Thanks!

At the moment your sites are proxied.
https://cf.sjr.org.uk/tools/check?11ee0aba3b64496ab70cd42e7f9e2d58#dns

I would suggest you pause Cloudflare (so it provides DNS only, and traffic goes direct to your origin). Get everything working at your end first with correct certificates and sites loading, working on HTTP and HTTPS, linking to your hosting plus email and anything else you use.

Only then unpause Cloudflare to enable the proxy and then you can see if anything breaks and fix that. (HTTP-01 challenge for Letsencrypt is most common, there’s some setting to make to support that)

Trying to debug and fix issues when you can’t see through the proxy makes it hard to work out what’s happening and if the problem is with your Cloudflare configuration or origin server setup.

Alright, I have paused cloudflare completely so it doesn’t proxy and used DNS only. I have checked, I can resolve for example veelaerthome.be:9443. This will correctly go to my portainer instance so it does seem that something of the domain resolves so now how would I go about getting the ports removed by using the subdomains and such and that it will use https? Cuz the current resolve still only uses http :frowning:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.