My DNS Settings Ignored?

I am connecting to the Internet through the router (Linksys WRT1200AC running OpenWRT) which is in turn connected to the ISP’s modem (FritzBox 6660 Cable) in bridge mode. I have set 1.1.1.1 and 1.0.0.1 to be my DNS servers on both devices. However, when running the DNS Leak test on page https://www.dnsleaktest.com/ I get one entry for Cloudflare and four more that belong to my ISP. Why are my ISP’s DNS servers appearing?

Check the DNS config on your client devices (computer, phone, etc). If your ISP’s nameservers are in there, they can bypass your router’s DNS config. Your ISP’s nameservers might be getting added via DHCP. Also make sure, if you are using IPv6, that you also have only Cloudflare’s IPv6 DNS addresses configured; if you have no IPv6 nameservers configured then it will likely use your ISP.

Thank you!
My ISP does not provide IPv6 and just for a good measure, I have also disabled IPv6 on my router. All my client devices are set to receive the DNS servers via the DHCP and I have set those to be 1.1.1.1 and 1.0.0.1 on the DHCP server. To add to my original post: when I run the test on https://www.dnsleaktest.com, in addition to Cloudflare and my ISP’s DNS servers, occasionally I also see a lot of servers with names like A123-205-116-48.deploy.static.akamaitechnologies.com. The numbers after the initial A correspond to the server’s IP address.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.