My default domain is redirecting me to my custom page even when deleted when deleted only fix is to disable proxy on dns

I had a custom page rule that redirected to another site i removed it as i didnt need it no more but ever since removing searching up my domain brings me to the redirect page i clear cache ect only way to fix is by disabling proxy for the dns servers from my website

May I ask if you’ve cleared the cache in your Web browser? :thinking:

How about purging the cache at Cloudflare dashboard → Cache → Purge Everything? :thinking:

Have you tried using a different Web browser or incognito mode for testing?

And you don’t see that particular Page Rule listed anymore?

I have done all that and there are no page rules listed anymore i have tried login in to cloudflare on phone other pc to check incase its a visual bug but still happening it doesnt redirect me if i change my dns records to not proxied

Thank you for feedback.

Therefrom, you don’t use Cloudflare Worker to perform a redirect, neither Redirect Rule (different than Page Rules), neither Transform Rule which could potentially inherit “in between”? :thinking:

May I ask you to post and share your domain name in bracketed dot [.] notation (example[dot]com) here so we could double-check, troubleshoot and provide some more feedback information? :thinking:

i don’t understand sorry do you wamt me to sent my full domain name?

Yes.
Otherwise, if not I’d suggest you to check yourself with curl at least, if something is redirecting from the Cloudflare edge or rather origin, or plugin, application, maybe the SSL certificate, etc. could be “in between”.

Looks a bit mysterious at this point. So basically you only change the proxying status and nothing else?

Without knowing and trying to figure it out, in that way, it is somewhat impossible to debug and troubleshoot except if you write to the Cloudflare Support and go through the ticket.

([Lumixmc]net) - the forwarding domain that i had that i deleted was a discord link for domain
(discord [Lumixmc] net) and thats whats forwarding to is i enable proxy on cloudflare

Seems like Malware content rated (at least by my Malwarebytes Premium and Eset Internet Security), which is why you’re redirected :thinking:

HTTP/1.1 303 See Other
Location: https://block.malwarebytes.com?lic=Licensed&cat=Compromised&lang=en&prod=MBAM-C&ver=4.6.7.301&cpv=1.0.2222&upv=1.0.79221&ldr=352&ip=xx.xxx.xxx.xxx&url=lumixmc.net
Connection: close
curl: (35) OpenSSL/3.0.12: error:0A00010B:SSL routines::wrong version number
curl: (60) SSL: no alternative certificate subject name matches target host name 'lumixmc.net'

Since now it’s not :orange: , I got HTTP 200 from the origin host over HTTP:

HTTP/1.1 200 OK
Server: nginx

Seems like you don’t have SSL certificate which covers your domain name neither.

NET::ERR_CERT_COMMON_NAME_INVALID
Subject: web1.revivenode.com

what can i do to fix this

I can suggest you firstly to get an SSL certificate for your domain name first, install it therefrom make sure you’re using Full (Strict) SSL option from the SSL Settings at the Cloudflare dashboard for your zone.

Helpful article to properly setup and configure SSL:

how do i fix when enabling proxy on Cloudflare dns it redirects me to my discord link even with the default domain name

Can you enable the proxy :orange: now, write back so I can check again, just in case? :thinking:

Despite, we should fix first things first, then move on to the next to solve your issue :wink:

Proxy is now enabled and i have and enabled full sriked ssl in the cloudflare settings

Would broke things before the stated “first” about fxing the SSL issue.

Would be good to understand the SSL settings first as stated in the link above for the article, then go after the correct one.

I do see the 301 redirect here, and cache-control settings for 1 hour too:

HTTP/1.1 301 Moved Permanently
Date: Thu, 04 Jan 2024 02:51:59 GMT
Connection: keep-alive
Cache-Control: max-age=3600
Expires: Thu, 04 Jan 2024 03:51:59 GMT
Location: https://discord.gg/U6FXscy762
Server: cloudflare

What have you got selected here?:

Could you change it to the “Respect Existing Headers”.

Furthermore, are you using any other Page Rule for caching?

After that, hit “Purge Everything”.

I have enabled the respect thing now and cleared cache:)


these are the other current settings i have


shown here i have no page rules