My cPanel not displaying correctly

ssl
dns

#1

I put a request in Cloudlare Request #1462091 but it’s been 6 hours and no reply there
so posting in community

I have setup Cloudflare only 2 days ago and website is not displaying correctly:
http://www.ubts.com.sg/services/airport/customer-service-agents/

Images are not loaded for sub-pages and my cPanel also not showing correctly (no icons or images)
see new cPanel look

Can anyone assist pls?

Thanks


#2

The website shows up properly for me.

Is cPanel on a subdomain, or is it using a special port? :orange: will only proxy certain ports:


#3

The images appear to call from a different subdomain and there’s no www record for that domain:
http://www.ubts.sg/wp-content/uploads/2014/04/Untitled2.jpg


#4

is on standard 2083 port.

I can login, is just that looks so different without icons and pics, that I cannot select anything

This is how it looks now:
new cPanel look

This is how it used to look:


#5

How does the cPanel login screen look? For me, it looks fine and no errors are listed. You’re typing in https://, right?

If your cPanel login screen also looks good, but cPanel itself looks sparse, as in your screenshot, open up Dev Tools in your browser and see which resources are causing trouble and why. In Chrome and Firefox, it’s something like Command-Option I (capital i).


#7

Login is fine, but as you say after login cPanel looks sparse,
Not sure how to change what Dev Tools are used for my Google Chrome,
am using version 63.0.3239.84 (Official Build) (64-bit)


#8

OK, figured out how to go Dev Tools.

Here is the console screen:


#9

cPanel seems to have some quirks when being served from behind Cloudflare. I see that https://cpanel.ubts.com.sg/ also gets you cPanel. If you can :grey: that DNS entry, that might help, though it will publicize your origin’s IP address. That’s all I can come up with. Maybe someone else has an idea.


#10

Thanks. It was already grey clouded when I started;
but still looks sparse.

Thanks for your help anyway.

Much appreciated


#11

Ack! You’re right, it is :grey:. In that case, it’s clearly an issue with your server, and not Cloudflare. Time to start bugging your hosting company for a solution.


#12

This is not unheard of for customers on FREE plans. For faster support you may want to consider upgrading to a paid plan. Responses for paid plans often arrive within minutes or hours. Free can vary considerably.

I also see that an engineer has responded on your ticket. Please follow the instructions in the ticket.


#13

Thanks sdayman.

The hosting provider really not helpful.
I asked them to help me download the config files for cPanel
and they totally blew me off.

Will start looking for another hosting company.


#14

Thanks Ryan.

Will do


#15

I have the same issue here. If I access my server using its IP address everything works like a charm. However If I use: https://mydomain:2083 then the cpanel will load-up but with the icons missing. Also the session doesn’t last. How to solve this issue.
At the moment I have ports
80, 433, 2086, 2087, 2083, 2084 enabled on my server Do I need to allow for more ports?

Regards.


#16

Actually, Cloudflare recommends to use cpanel.yourdomain.com instead of yourdomain.com/cpanel or yourdomain.com:2083 as it has trouble proxying it, but most of the time if cpanel.yourdomain.com is proxied through Cloudflare it should work, but a bit slow. if you really want to hide your IP, then you should CNAME cpanel.yourdomain.com to the server hostname instead. it won’t hide, but will require search and can fool hackers