My CNAME records are always proxied although I turn them off

Hello all,

does anyone know why my CNAME records are switched on automatically even after I turn them off?

Regards,
Alejandro

What is the domain and CNAMEs you are having problems with? Can you show a screenshot of your DNS records?

Hello sjr,

Yes the domain is clinlife . de and here is the screenshot:

By this, do you mean for say www, you edit the record and turn off the proxy (to “DNS only”) and it switches back to “proxied”?

If so, make sure you press “save” after making any changes to each record. Just pressing the switch doesn’t make that change as it does on other dashboard pages.

All the “DNS only” CNAMEs are ok…

dig +short lyncdiscover.clinlife.de
webdir.online.lync.com.
dig +short autodiscover.clinlife.de cname
autodiscover.outlook.com.
dig +short bnc3.clinlife.de cname
bnc3.mailjet.com.
dig +short lyncdiscover.clinlife.de cname
webdir.online.lync.com.
dig +short msoid.clinlife.de cname
clientconfig.microsoftonline-p.net.
dig +short sip.clinlife.de cname
sipdir.online.lync.com.

My issue is that the ones that are now with the proxy activated, they cant be deactivated. I found this article:


But it should not applied as I want to deactivate proxy on all records.

Have you actually tried to go to each record in turn on the DNS page, press “edit” and switch the proxy off? (don’t forget to press “save”)

I’m not sure if you are doing this, and you say it’s not working. Or if you are just not taking the steps to turn the proxy off.

2 Likes

To add on to sjr’s reply, you should check your audit log to see if/when the records were edited Review audit logs · Cloudflare Fundamentals docs

If you are sure that you turned proxy off and it turns on again, it sounds like you could be using a third party service that has access to your Cloudflare settings.

1 Like

Yes, I do switch them off, after 1 min they are on automatically, here is a screenshot:

then same screenshot few min later:

Oh… it’s not that you can’t turn them off it is that you have configured a 3rd party tool such as Ezoic to manage your DNS settings in Cloudflare. Manage the settings in that tool or disable the integration or change your password and rotate your API key.

3 Likes

Thanks! We indeed manage the dns records with an API, will check that right now!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.