My CNAME point an old DNS record

Hello,

I’m trying to switch on the “Proxied” option on my WWW to improve the performances of my website but every time I switch on and then try to access to my website, it redirects me to my old website (an old DNS record that I’m absolutely sure I’ve deleted) instead of my new one (CNAME to the main domain).
Do you have an idea ?

Best,

Hi @cpostic,

Perhaps you have an old Page Rule that you forgot about? :slightly_smiling_face:

Hi @albert,

Thanks for your answer.

Sadly nope, I really checked everything …

And this only happens when the record is proxied, right? It works fine without proxying?

Could you share the domain so we can take a look?

If you can, it would be much better to use A type than a CNAME record.

Do you consider having only non-www or only www? Meaning, you would have to have a Page Rule for redirection from non-www to www or vice-versa?

https://support.cloudflare.com/hc/en-us/articles/200172286-Configuring-URL-forwarding-or-redirects-with-Cloudflare-Page-Rules

https://support.cloudflare.com/hc/en-us/articles/218411427-Understanding-and-Configuring-Cloudflare-Page-Rules-Page-Rules-Tutorial-

Maybe you have to wait for some time to apply the changes due to the TTL (from the old DNS) for that www record.

Yes, that’s what’s driving me crazy, once I set the parameter to DNS only, it works perfectly and once I activate proxy, I have my old website (which is a real issue as it is in production…).
the website is www.misaki.com

The changes are applied because I first have my new website and once the Proxy is enabled, I have my old one.
And it’s a WWW with à CNAME that point to the root domain, and the root domain that point to the IP, sounds good to me nope ?

Was your old Website working over HTTPS, while the new one not?

It could be due to the SSL certificate, maybe, as if the SSL/TLS option which could be due to the selected option under SSL/TLS tab at Cloudflare dashboard for your domain like, for example Cloudflare connects to HTTPS only (old website) due to the selected option while the new Website does not have a valid SSL certificate and cannot connect to it over HTTPS - which is why it could show you an old website.

Also, kindly re-check if you have got some redirection at your origin host/server, if so, maybe left from the development phase, etc.?

Usually, if you know the IP you would have:

  • A misaki.com → pointed to the IP and :orange:
  • A www → pointed to the same IP and :orange:

Example:

Thanks a lot for your answer !
Nope, good idea indeed but they are both working over HTTPS.
Alright, I can do it this way, I just usually have the A record on the root domain and the CNAME on the WWW.
I’ll replace the CNAME record by a A record and I’ll tell you

1 Like

And do not forget to wait for some time for the DNS to apply the changes :wink:

Of course!
But usually I know that it didn’t work when I see my old website instead of the new one :grinning_face_with_smiling_eyes:

So I try to activate the proxy with both A records ?

I just cleared the Cloudflare cache and I now have my old website again…

Hm, but have you cleared your Web browser cache?
Have you tried accesing it via Private Window, or a different Web browser, or via VPN connection?
May I also ask have you tried reseting your home router due to the possible DNS cache by your ISP?

This is what I see on www, while non-www redirects me to www (working great :+1: ):

Yes I did and it’s indeed my old website that you see, see how it’s crazy ?

Yes I did and it’s indeed my old website that you see, see how it’s crazy ?

I disabled the proxy a few minutes ago and I now have the new website …
Still the same issue, can’t explain why :frowning:

The most likely cause is that your site used to be under control of a third party Cloudflare Partner, so when you :orange: Proxy that hostname, it starts using that third party service again.

Although…it looks like your domain has been on Cloudflare for two years. And only now this problem is happening?

I just installed the domain on Cloudflare, I was using a PaaS website (Oxatis) so they could have used Cloudflare…
Do you have any idea how can I bypass the their system ?

You’d have to ask the old host (Oxatis?) to remove your domain from their system.

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.