My cloudflare ssl is active but still my website is showing not secure

My wordpress website primalcalisthenics.com is showing not secure. I don’t what happened and I don’t understand what to do. Please help…

Looks good from my browser, also this third party test site says everything is in order:

https://www.sslshopper.com/ssl-checker.html#hostname=primalcalisthenics.com

Your browser is probably caching the previous status of the site, clear your DNS cache and browser cache/history. Should take care of things.

Recently, I hosted a Wordpress website primarycalisthenics.com and added SSL through Cloudflare. Now my website shows not secure when added https. I don’t understand what happened and what to do now. Someone suggested me to flush my DNS, clear cache and history of my browser and try again but still the problem remains the same. Please help…


This picture shows when I add https to my domain name. It shows me some kinda internal ssl error
and
When I open my website with http it opens but shows website is not secure.

My website was working normal till morning and afternoon but after i was adding some functionality to my wordpress website using feedburner and this hapened. I dont this happened due to that functionality or some other reason

Need help…

Works fine here when opening URL by SSL. And when opening URL by non-SSL (http), it correctly redirects to HTTPS. Seems like you have a scenario where your ISP’s DNS is not propagating correctly yet, and the url is not passed through Cloudflare in your case.

Did you recently set up the DNS and/or toggle Cloudflare-cloud in DNS settings? Seems it should be working for you shortly

I don’t know what just happened, now it’s working fine and someone please explain why this would have happened so that I can be little careful or what should I do if this happens in future.

Hi @rohithchigullapally,

Probably a cached value at your end that caused your requests to go directly to your server and not through Cloudflare.

This topic was automatically closed after 30 days. New replies are no longer allowed.