My caching is jacked?

Hello, good people.

I have a site hosted over at CloudCannon. It feeds through Cloudflare. You can view the site at https://strongsenseofplace.com. It’s a jam stack built with Jekyll.

I updated the site two days ago. Here’s the observed phenomena:

  • The post that I want to see at the top of my index page is not visible on desktops. (Desired post is “Walk the Cobbled Streets of Love and Memory in the Novel ‘Haunting Paris’.” Post displaying is “SSoP Podcast Season 3: Announcing 12 Amazing Destinations.”)
  • The post that I Want to see at the top of my index page is visible on phones.
  • I confirmed this locally and through browserstack.com.
  • There is no problem through the staging server, which is served directly from CloudCannon.

Caching problem, right?

I go to Cloudflare’s caching buttons, click both “Custom Purge” and “Purge Everything,” and wait for a few hours.

Same problem. No changes.

Does anybody have any ideas?

Thank you!

  • David

Cloudflare isn’t caching your HTML. But there’s a cc-cache-status: HIT in the headers.

It also looks like you’re using Ezoic, which you didn’t mention. Is this correct?

You are correct, sir. – Ezoic was the culprit. I turned off caching over there. Fixed!

Thanks for the note!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.