My "Always use HTTPS" redirect was working a few minutes back, why isn't it working now?


#1

My domain yeskay.me has Universal SSL enabled. I enabled “Always use HTTPS” option and I was trying to setup URL forwarding from yeskay.me to www.yeskay.me in the page rules, it resulted in infinite redirects, so upon failure, I removed the page rule. After that, when I visited the yeskay.me, https://yeskay.me, www.yeskay.me- all of it went to the http version of the website - http://yeskay.me. After turning the Development mode on and waiting for sometime, the behavior was such as this:

yeskay.me goes to http://yeskay.me
https://yeskay.me goes to https://yeskay.me
www.yeskay.me goes to yeskay.me

I have a CNAME of www setup as alias of yeskay.me so it should go to www.yeskay.me and show contents of yeskay.me, but it’s getting redirected to yeskay.me. How do I fix this? Also, I would want yeskay.me to go to https://www.yeskay.me, how do I achieve this in cloudflare level?

Update:

https://yeskay.me gives a “Connection not secure” error message now.

Second update:

yeskay.me and www.yeskay.me are in redirect loops now, I haven’t touched the settings at all.


#2

Answered in your other thread.