My A record is apparently set wrong but I can't fix it

I transferred my site to cloudflare about 12 hours ago and I know that the global propagation has now fully updated globally. But my site is still not showing. Blue host doesn’t seem to be able to help but the support thinks my ‘A’ record was set wrong or is pointing wrong.
Most of my records are set to the bluehost IP address correctly but there are some records set to 127.0.0.1 and Blue host thinks this is wrong? They say I should set them to the cloudflare IP address?

https://www.whatsmydns.net/#A/my-lead-system.com

This is very confusing and I don’t know if I’m asking the right questions.
I’m just wondering how to configure my settings so my site at bluehost becomes live.
Thank you.

Edward

They are wrong. Your site isn’t hosted at Cloudflare. It’s hosted at Bluehost and needs to have Bluehost IP addresses in your DNS page.

Right now, your DNS “A” and CNAME records for my-lead-system and www are correct and your site loads its Down for Maintenance page.

To activate Cloudflare for your website, those two DNS records need to be set to :orange:. They’re currently set to :grey:.

Oh wow thank you so much! I’ve had a nightmare chatting with Bluehost support none of them have helped at all. You on the other hand are very helpful indeed! Thank you so much!
Right now I see 14 grey cloud icons on my list of DNS records and none of them are orange I think there were some orange yesterday that also said proxied but blue hosted told me to change them to DNS only which I did and now they’re all grey.
Sorry which 2 items do I need to switch from Grey to orange cloud icons?

Thanks again.

I think it’s all now fixed thanks to you.
As you said I changed all the grey cloud icons to orange and also there were 2 records set to 127.0.0.1 that needed to be changed to the bluehost IP address (Bluehost told me to set it like that but they were clearly wrong)

Anyway I’m very grateful to this forum, and cloudflare for your help.
Edward.

The only catch on setting DNS records to :orange: is that Cloudflare can’t proxy email. You have an MX record, but it points to a hostname that is set to :orange:.

Cloudflare does a good job of hiding it, but you may find that your email app can’t send or receive email. Maybe. Here’s a tutorial on that:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.