MxTools issues - emails going to spam

Hello,

I was told by my host that my emails problem (going to spam) was coming from my Cloudflare configuration.
Here are the errors I get from MxTools:

Would you know if they are related to the spam issue and how to fix those?

Thanks for your help CloudFlare Community!

From the screenshot above, I see dc-something, kindly check below article here:

The dc-##### subdomain is added to overcome a conflict created when your SRV or MX record resolves to a domain configured to proxy to Cloudflare.

Do not orange-cloud DNS records used to receive mail: Cloudflare does not proxy mail traffic by default.

Seems like your A type mail DNS record is set either to :orange: cloud (proxied) and/or your MX type DNS record points to yourdomain.com (which is also :orange: proxied), while it shuld be rather pointed to an unproxied :grey: cloud (DNS-only) mail.yourdomain.com hostname.

Cloudflare’s default configuration only allows proxying of HTTP traffic and will break mail traffic.

  • The hostname (DNS record) used for e-mail send/receive should be :grey: cloud (usually it’s the A mail ), while the MX record should point to a hostname (usually the A mail ) that is set to

I recommend to re-check things mentioned in below articles how to propperly setup e-mail configuration to make sure it works while your domain is using Cloudflare:

Kindly, see here:

2 Likes

thanks so much, @fritexvz for your fast and thorough answer.

so this is what I have now, I can see the warning with the MX record:

I updated it to vps64206.inmotionhosting.com which is the recommended server provided by my cpanel. (It shows I can use mail.3angles.consulting, but it’s for non-SSL and not recommended)


Is that the right thing to do?

I don’t have a A record for mails, should I create one?

Thanks again

Definitely. The good news is you already know the IP address. Make sure you delete the CNAME for ‘mail’ before creating the “A” record, and that the “A” record is :grey: DNS Only, as @fritexvz recommended.

1 Like

Great! thanks @sdayman. So should I do:

A - mail - IP address - Auto - DNS only

or

A - mail - vps64206.inmotionhosting.com - Auto - DNS only

It has to be this:

1 Like

cool!
so here is what shows now, I supposed the warning is normal and to be ignored?

Correct. That’s unavoidable when you host email and a website on the same server. You can hide the website’s origin, but not email.

2 Likes

If I may mention, I also see the CNAME smtp being :orange: (proxied).

As by what I assume the usage it is for (sending e-mails?), may I suggest removing CNAME smtp, therefore creating an new A smtp with the content value of your server IP and :grey: cloud (DNS-only).

If you are accessing to your FTP using the hostname ftp.yourdomain.com, it is a good practice to make it :grey: cloud (DNS-only) too.

Even better way would be to use directly the IP address for the hostname (in FileZilla, etc.) and remove the A ftp from the DNS records list :wink:

2 Likes

done!

Deleted the CNAME smtp and ‘A FTP’ and created a A SMTP with the IP.

Tested the ftp connection with IP with Coda and it works nicely

2 Likes

Hello fine gentlemen, it looks like the issues are still showing on MxTools and I believe my emails are still going to spam :confused:

May I ask have you try sending and receiving your e-mails?

Furthermore, have you checked when using your e-mail client, if your e-mail client (MS Outlook, Mozilla Thunderbird, Apple Mail, etc.) have incomming/outgoing (POP3/IMAP/SMPT) server set to mail.yourdomain.com (and you have had smtp.yourdomain.com too somewhere above) instead of yourdomain.com?

Therefore, are you using secure (SSL) connection and good ports?

Have you tried testing with some online tools like https://www.mail-tester.com/?

I do receive my own emails, but I’m assuming I’m already whitelisted.

I have the server hostname in the client settings :

and I got 10/10 in mail-tester.com

I should probably mention that I use apple mail with Mailbutler, which helps with tracking when emails when opened. It also has a complex HTML signature generator.

I’m hoping it is not the cause because I still have the issues mentioned in my first post (SOA, Reverse DNS, TLS, Transaction time) but really not sure what they are