MX Records not saving to @

My email on both domains hosted with Cloudflare are not being sent or received. Go Daddy is suggesting that the settings are not being saved correctly and Cloudflare. The setting that is being added is the MX @ record. When being saved the domain shows up as the name. Is this correct? Also do I need to delete the Go Daddy zone for mail settings?

Why in MX setting Cloudflare suggest @ Use @ for root but entering @ it resolves to the domain?

Don’t orange-cloud your mail server. Don’t orange cloud anything that’s going to be used for non-HTTP traffic (for example, SMTP).

fix that then try to create your MX record again. should look like this:

you only need an MX record for @, assuming you’re not trying to receive mail on subdomain e-mail addresses

3 Likes

Hi thanks for the input.
So I did change CF DNS settings as suggested.
I am testing send receive again gmail and still no email results
Any suggestions


would be appreciated…

You need to have an A or CNAME record for your mail server it just needs to be grey-clouded. It seems like you completely deleted it instead of grey-clouding.

And then edit your MX record and change the Name field to @

thanks user4358
when adding or editing the MX record with @ it always reverts back to the domain name…

I add MX | @ | mail.gourmetmeats.ca | check “DNS ONLY” | 0

and the @ reverts to gourmetmeats.ca

That’s what @ is supposed to do. It’s right.

2 Likes

ok thanks…I guess Ill need to wait awhile for propagation…

Looks fine from here.

1 Like

Well something is still not right. In godaddy webmail I get ‘SERVER ERROR’ message. Test emails evaporate.
Sending test emails from gmail I get error notice bounce " The response from the remote server was:

550 Please turn on SMTP Authentication in your mail client. mail-oi1-f182.google.com [209.85.167.182]:46937 is not permitted to relay through this server without authentication."

again…im using webmail…not software clients to read send email…

It sounds like when you send e-mail from Gmail to your domain, Gmail’s server is reaching your mail server but your mail server is refusing to accept the message. Port 25 on the server is reachable and you can telnet to it and interact with it via SMTP commands. So network connectivity is good & it’s not any kind of Cloudflare issue. If the mail server is refusing to accept mail or otherwise misbehaving, its configuration needs to be checked. And I see it’s actually a server belong to a certain infamous service provider so you’ll probably have to talk to them about it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.