MX records: gmail won't obey

Why does Gmail insist on sending emails to the OLD mail host after I’ve updated MX Records to point to a new mail host?

Emails sent from gmail to one of the email accounts I’ve migrated from tsohost to mxroute still land in tsohost mailbox. Sending from a different email sender account, they land in the right place on mxroute…

How long ago did you update it? Whats the domain?

domain: thepilatesfoundry.co.uk

Changes made earlier today. MX records have propagated around the world (https://www.whatsmydns.net/#MX/thepilatesfoundry.co.uk)

BTW. I’ve migrated half a dozen other email accounts today with ZERO issues and immediate correct routing of emails sent from gmail (loaded in a browser) to the affected email address - without exception, all those emails were delivered to MXRoute correctly within minutes of the MX records being set at CF

The domain does point to two mxrouting.net hosts. The domain itself also appears to be correctly configured from a DNS perspective.

Overall it should work fine and if Google delivers it incorrectly, my best guess would be some caching on their side. If they still don’t deliver correctly in the next couple of hours I’d contact Google and clarify the issue with them.

Thanks. Going to try migrating a 2nd, 3rd and or 4th email account from the old host to MXRoute now. Spent far too long trying to figure this out and realised there’s no logical reason that I can control for this happening, so best crack on and trust it will rectify itself.

You could try to remove all MX records and then check how Google reacts, but in general the DNS configuration on Cloudflare looks okay

nslookup -type=mx thepilatesfoundry.co.uk rob.ns.cloudflare.com
Server:  rob.ns.cloudflare.com
Address:  173.245.59.140

thepilatesfoundry.co.uk MX preference = 10, mail exchanger = echo.mxrouting.net
thepilatesfoundry.co.uk MX preference = 20, mail exchanger = echo-relay.mxrouting.net

At this point I am afraid only Google can explain why they keep sending to the previous server. I’d assume caching, but that should not go on for hours.

I will only worry about contacting Google IF the 2nd email account I try migrating is affected too, because the first one I ran through the process is one we don’t use but want to persist the mail archive on our new mail host.

I even just found and tried this… to no avail: https://google-public-dns.appspot.com/cache via this thread: https://support.google.com/mail/thread/8448802?hl=en

Depending on what you made the change I’d simply wait a bit more and then contact them should it still not work.

When you say “Contact them” @Sandro, what do you find works - all I can see are community groups… Do you have a recommendation of ‘where’ to contact them to get a technically qualified person reply please?

One other thing you could try is to disable DNSSEC. It does not seems as if there was an issue, but should there be then this might explain why they stick to a previously verified value and ignore the new one.

I’d disable it only for testing though.

Don’t think I got around to ‘enabling’ DNSSEC yet

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.