MX records are exposing IPs

Hi! I’m getting this message ‘Some of your DNS only records are exposing IPs that are proxied through Cloudflare’ for the MX record (I only have 1 MX record).
I have the following settings for the MX record in place:
Name: domainname . com (without spaces)
Content: mail.domainname . com (without spaces)
TTL: Auto
Prioroty:0
DNS Only
All my mail is being redirected from the server to Gmail (direct integration, not GSuite). I’m not this matters.
I’ve already read through several threads related to DNS settings but I couldn’t find an answer to my question. I’m not tech-savvy and this is all new to me.
I’d greatly appreciate some tips as to what should I do.
Thanks!

That’s normal and unavoidable if you process email on the same server as your website. Cloudflare does not proxy email connections, so it has to be :grey: DNS Only.

Thanks, @sdayman So if I understood correctly, I should just leave it be and move on? I don’t have to delete or edit the MX record in any way, right?

Correct. If incoming mail is working, you’ll have to leave it alone.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.