MX record problem

I have the A record pointed to the IP. And I have one MX record which gives me the warning about IP exposed. If I grey cloud the A record the MX won’t have the exposed IP warning but the A record will.
And Vice Versa. And I can’t get my emails to work. Instead of changing the name servers to cloudflare…is there a setup just for the Domain to be using CDN???

A proper mail setup would have the MX record point to, with an “A” record for that’s set to :grey: DNS Only. If you host email and the website on the same server, which is common with shared hosting, you will need to expose that server’s IP address in order for mail to work.

This is the way.

So how should I change this setup?

Like what @sdayman mentioned, you need to grey cloud the records used by your mail server.

That’s normal to see the triangle warning - you have to expose your IP address in order for mail to work.

1 Like

The mail is not working with these settings!! What else do I need to do?

Disable proxy for

Disable proxy? I’m not sure how to set this up. Is there a way for me to just use Cloudflare for A records? And keep the nameservers at hostgator?

You mean the one for webmail? There are no other clouds for mail.

You are pointing mx record to mail atbayaappliance com so please check cname or A record that set and disable proxy (Orange icon) for that. Make sure that Cname (or A record is in Grey Icon with DNS Only)

Is this correct now?

That should solve your email deliverability issues, as long as all your phone and computer Mail apps use the ‘mail’ hostname for sending and receiving email.

You don’t need to :grey: the ‘webmail’ hostname because that’s a webpage. It’s a little confusing because it’s about mail, though it should be configured to send and receive through the ‘mail’ hostname as well.

No, it still isn’t working

Your ‘mail’ hostname is a functioning mail server for sending (SMTP) and receiving (POP/IMAP). As this is a direct connection, and not handled by Cloudflare, you need to resolve this with your mail host.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.