MX record is not propagating Not able to login to outlook client

My MX record Is not Propagating I change nameservers 20 days ago forms on my site is working fine but email created with C panel see an error message when try to login to outlook mail client showing error outgoing server error please update you server configuration to connecting to this server I have all record configure
sharing pic of all DNS record```

I need this fix ASAP looking for assistance really quick
website link 
Thanks in advance

You need to unproxy your mail hostname in order for it to be available for mail delivery. Then your MX record will resolve properly.

Edit that mail hostname and toggle it to :grey: DNS Only.

1 Like

can you please guide me how can I do it

Thanks for you help This is what you are suggesting right

![Cloudflare DNS 2|690x361](upload://57f7Y9c1zsahvmP69p3Pm4gx7Rv.png)

In My outlook I’m seeing this error can you help me with it with all there onpointsale emails

![outlook error|414x369](upload://AlVVUztCWTpLYkqUBPuhcfb9f5g.png)

I can’t see your uploads and this probably doesn’t affect your client, but also you have multiple SPF records for your apex domain when there must only be one.

1 Like

That’s the hosting ask me to create these records could you please suggest me which record should I remove

It seems to me like you’ve already made progress, according to the explanations above, however:

The TXT (SPF) record for your naked domain, where the content is currently:

v=spf1 a mx ptr -all

You should take away the “a mx ptr” part from that, so the final content becomes:

v=spf1 -all
1 Like

Done what should I do next Is this fix problem Instantly or I have to wait for Propagation period

It’s done…

But the email is still not working

Still same outlook error for send/receive [Preformatted text](

Your Cloudflare settings are now correct and a mail server at Godaddy referred to by responds on all mail ports. You will need to check the settings in your mail client. The Outlook error is between Outlook and Godaddy, nothing to do with your Cloudflare settings.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.