MX Error Cloudfare bad hostname

Hi,
If i define MX mail.mydomain.com cloudfare why overide to
0 _dc-mx.9958ad544490.mydomain.com??

it would take days for me to mess up if i hadn’t resolved go to the page with smtp login -.-

They overwrite it because they don’t handle SMTP traffic, so it wouldn’t work as the mail.example.com subdomain is :orange:.

If you want to use that directly, simply set it to :grey: and bypass all proxying.

2 Likes

I am already set but Cloudfare arbitrarily adds that stupid hostname
with this as it appears in the photo causing an error in the dns

Cloudflare adds that hostname if, and only if, the entry you set in the MX record points to a proxied, :orange:, record. If that record has been changed recently to :grey:, it might take a moment to update. Delete the MX record and re-create it.

1 Like

Yes i added recentley!
Added MX
name: @
value: mail.domain.com
0, Auto
After added my server ip to mail A record

And the mail A record is non-proxied?

We are going in circles.
Delete the MX record after you make sure the mail A record is non-proxied, :grey:, and you don’t have any other mail A/AAAA records anywhere, and re-create it.

1 Like

aaaa now discover NON PROXT Ico…
And this is resolved!
Thanks Matteo!

In my www and domain ping apper this 2 *(double) ip: [172.67.171.197] [104.21.55.171]
This is correct?

This is the normal Cloudflare behaviour.

1 Like

ok,
Short if i disable proxy and only DNS same not use Cloudfare?

If you disable proxying then yes, it will not use Cloudflare. For your site, it should be proxied. Just email records should not be. Cloudflare handles HTTP(s) requests

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.