Mx and txt record ttl stuck at 5 minutes


#1

Hi,

I am trying to verify a domain, that has it’s DNS managed by Cloudflare in Azure AD. I set the txt and/or MX records needed for verification as requested by MS. And the verification fails. When I dug into the issue, I discovered (by checking the DNS entries via MX toolbox) that TTL for those verification entries is set to 5 mins. I have manually set it to 1 hour (as requested by Azure) yet this setting seems to have no effect on actual DNS entries - they still show 5 minutes.

Anyone ever experienced something similar? Anyone knows how can I get the TTL to actually change?


#2

We have Exchange mail set to 30 minutes without any issues.


#3

You mean that exchange works with ttl set to 30 mins or that it passed verification? Ms tells me that I need to apply all the settings to verify the domain, including ttl :confused:


#4

My apologizes for the delay, it’s been a few years and had to review our notes. Verification was originally done with text (MS=ms123456) and our MX in Cloudflare is 30 minutes.
You should add both the text and MX records to Cloudflare. Setting MX TTL to the recommended 3600 reduces queries but shouldn’t affect verification. if you already had 30, just click it and change to their preferred 1 hour. Then verify in Azure Custom domains.