Multiple Tunnels Same Server

I have a thinkcenter with Jellyfin and Kavita on it but I’d like to access them from outside the home. I can get 1 tunnel working going to just Jellyfin. I have no idea how to get both of them at the same time because it seems really overly complex. When I go to set up a new tunnel on the same server cloudflared is like no you can’t because you should delete the old one so the new one will work. I don’t want them to go to the same port or any of that. I don’t understand what I’m supposed to do to get 2 things to function right from the go.

Use a single tunnel with mutiple ingress rules (or public hostnames using Zero Trust Dashboard Tunnels).

If you are using the Zero Trust Dashboard, it makes this (and everything else) extremely easy, just add another Public Hostname, it’ll take care of the DNS Records for you.

If you’re using CLI Tunnels (manually editing config.yml), use ingress rules to route your requests


tunnel: <snip>
credentials-file: /root/.cloudflared/<snip>json

  - hostname:
  - hostname:
  - service: http_status:404

You’ll need to create the necessary DNS Records as well, a CNAME pointing at your tunnel. You can use cloudflared tunnel route dns <name> <hostname> or copy the existing CNAME Target and create it manually.

CLI Tunnels and Yaml can be confusing and annoying, especially for beginners. I would really recommend you take the time and set up your tunnel from the Zero Trust Dashboard. Then you manage your tunnel entirely within the Dashboard/Website and it takes care of creating necessary DNS Records and such for you, and instantly applies your changes to the tunnel. The Zero Trust free plan does require a payment method for anti-abuse, even though the free plan is free and wouldn’t charge you if you go over any limits, but it’s well worth it. The guide to set one up is here:

1 Like

I did it with the dashboard and then copy pasted some stuff it gave me and then pressed enter in the cli. I also updated the cloudflared I set up on it a month ago so yay for me but I’ll try out the egress as that seems a lot less ■■■■ to deal with and I’d like it to just work. I appreciate the reply and the assistance.

OK I get what I have to do but I’m still pretty confused. The documentation doesn’t say go here do this done. Go here done. Handled. I’m a bit new at this but I’ll try and figure this out myself before anyone ads a reply. Its’ just so not clear. They need to make their documentation for old people.

—I can’t edit my post which is lame. I get that I’m new.

I added a public hostname in the tunnel that was created previously. Our hostnames are now

jelly dot merrikkka dot com (guess I can’t include links)

epub dot merrikkka dot com

and I put the port and everything else as I did in the previous one that just worked. The jellyfin one. I checked the DNS and yes it did add some weird nonse to the records for CNAME

jelly 77c9f798-31f7-40fd-99ed-d8f2aba3b8b0 dot cfargotunnel dot com proxied auto

epub 77c9f798-31f7-40fd-99ed-d8f2aba3b8b0 dot cfargotunnel dot com proxied auto

the thing is it just doesn’t go to epub dot merrikkka dot com then send it to the computer that’s running the thing. I tried fanagling with some egress nonsense and I get a:

Bad gateway – Error code 502

What happened?

The web server reported a bad gateway error.

page that says that Cloudflare is indeed working but the server is being dumb because I can’t figure it out.

That’s where I’m at right now. It’s definitely a confusing beast this Cloudflare. They need a tool that tells you what you did wrong.

this you did a link thing is also odd

I uninstalled the service on the server and sudo reboot and still nothing. Something tells me I have to do something on the server probably editing a file.

developers. Cloudflare. com/Cloudflare-one/connections/connect-apps/install-and-setup/tunnel-guide/local/local-management/configuration-file/

I have no idea where cloudflared is installed. Kind of odd that documentation is supposed assist in problems not create more.

I’m truly dumb. The kavita .service thing I put in /etc/systemd/system didn’t restart the kavita service and then obviously Cloudflare had nothing to go to so obviously it’s like what are you trying to have me look at dood? I manually restarted the Kavita service and everything is ok.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.