Multiple Domains with Identical Forwarding and DNS but Two Domains Return 522: Connection timed out errors

I have multiple domains that all have identical DNS settings, namely:

A @ 192.0.2.1 (as a dummy ip: Redirecting One Domain to Another)

and then I have my Forward Domain settings set in Page Rules.

Two of the domains return 522: Connection timed out errors

rajjava.com
thegamor.com

In the Diagnostic tool, the check which these domains seem to fail is DNSSEC

DNSSEC - but that’s not an enabled setting on any working domain which clear the check (e.g. jawa.ws)

EDIT: rajjava.com briefly currently moved to a Error 523: Origin is unreachable but has since gone back to Error 522

1 Like

That’s interesting that you mention a 523 because I got that too on my first ‘curl’.

On the DNS page for both, the two Cloudflare name servers listed at the bottom are Grace and Nick?

If so, then my guess would be that those two domains at some point were going through a Cloudflare partner that hasn’t released your domains from their :orange: Proxied configuration.

I get a 522 error for both domains on the first try


Error 522: connection timed out

Error 522 occurs when Cloudflare times out contacting the origin web server. Two different timeouts cause HTTP error 522 depending on when they occur between Cloudflare and the origin web server:

  1. Before a connection is established, the origin web server does not return a SYN+ACK to Cloudflare within 15 seconds of Cloudflare sending a SYN.
  2. After a connection is established, the origin web server doesn’t acknowledge (ACK) Cloudflare’s resource request within 90 seconds.

An HTTP 524 error occurs if the origin web server acknowledges ( ACK ) the resource request after the connection has been established, but does not send a timely response.

Resolution

Contact your hosting provider to check the following common causes at your origin web server:

  • (Most common cause) Cloudflare IP addresses are rate limited or blocked in .htaccess, iptables, or firewalls. Confirm your hosting provider allows Cloudflare IP addresses.
  • An overloaded or offline origin web server drops incoming requests.
  • Keepalives are disabled at the origin web server.
  • The origin IP address in your Cloudflare DNS app does not match the IP address currently provisioned to your origin web server by your hosting provider.
  • Packets were dropped at your origin web server.

If you are using Cloudflare Pages, verify that you have a custom domain set up and that your CNAME record is pointed to your custom Pages domain. Instructions on how to set up a custom Pages domain can be found here.

If none of the above leads to a resolution, request the following information from your hosting provider or site administrator before contacting Cloudflare support:

  • An MTR or traceroute from your origin web server to a Cloudflare IP address that most commonly connected to your origin web server before the issue occurred. Identify a connecting Cloudflare IP recorded in the origin web server logs.
  • Details from the hosting provider’s investigation such as pertinent logs or conversations with the hosting provider.

Makes sense but here’s the thing, these two domains were always Domains to Be Forwarded, they never hosted content. These used to work and they no longer do, and these are domains that have been transferred to Cloudflare as registrar many months or years ago.

And they are all on Grace and Nick because they are part of the same login.
http://rjawa.com has the same settings as http://rajjava.com but only the former resolves properly.

But there is no origin server, there’s no hosting provider. I’m using a Dummy IP and a Domain Forward Page Rule all within Cloudflare. The domains are registered with Cloudflare so there should be no outside operations needed as far as I know.

The settings and configuration are identical to http://garajpictures.com (which works) but http://rajjava.com doesn’t work.

Could you share a screenshot of the page rules tab for one of these domains?

2 Likes

Sure, here it is.

I think I saw Michael replying, but you need to get rid of the dot after the *

*rajjava.com/*

It’s also best to add a www DNS entry as well, and the Page Rule will match for people who like to type “www” in front of domain names.

2 Likes

Damn it, too easy to miss. Not sure how I made that error on just those two and not the others but fixed and fixed.

Yeah agreed, the WWW was an oversight as I was removing old unused host IPs and setting up the Dummy.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.