Multiple 500 errors when loading multiple photos in parallel

Hi there,
We have MODX(core and all packages are up to date) website here on Cloudflare. When Full SSL mode(previously the same issue was for Flexible mode too) is enabled we see that not all images load correctly. For MODX it’s enough to open WYSWIG editor and load resources from any image folder. About two dozen are loaded perfectly(previews are generated via phpthumb functional) before and after there are a lot of 500 code returns. Here is some helpful shot:

<title>500 Internal Server Error</title>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator at
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="7f081a1d121e0c0b1a0d3f0b0d1a1a1b101c0b100d0c521c1e51080b12510d05145112061d130a1a17100c0b51121a">[email&#160;protected]</a> to inform them of the time this error occurred,
and the actions you performed just before this error.</p>
<p>More information about this error may be available
in the server error log.</p>
<p>Additionally, a 500 Internal Server Error
error was encountered while trying to use an ErrorDocument to handle the request.</p>
<address>Apache Server at Port 443</address>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/Cloudflare-static/email-decode.min.js"></script></body></html>

As you can see Cloudflare returns this error, without SSL previews are OK. It seems to us this is some kind of CF protection against mass operations or something like that … please advise what it might be if you came across. A lot of hours spent, all fresh ideas unfortunately ended. (( Thank you!

That’s a 500 server error at your origin. When the Cloudflare servers themselves error, different HTML content is returned.

Try checking your server error logs.

Thank you Judge!

different HTML content is returned.
Can you please advise what exactly?

Here is other idea from Modx forum - mod_evasive Apache module, checking that now…

As @Judge already explained that error does not come from Cloudflare but straight from your server. Thats where you need to look for the error.

Just a guess, if you say it only happens when you download files concurrently it might be some connection limit or something similar on your server.

We’ve found something helpful inside apache logs:

[Wed Nov 14 04:25:12.572009 2018] [:error] [pid 463769:tid 139852674733824] [client] SoftException in Application.cpp:630: Could not execute script "//connectors/system/phpthumb.php", referer: https:///manager/index.php?a=browser&source=1&ctx=web
[Wed Nov 14 04:25:12.555661 2018] [:error] [pid 463769:tid 139852557235968] [client] SoftException in Application.cpp:630: Could not execute script "/
/connectors/system/phpthumb.php", referer: https://*/manager/index.php?a=browser&source=1&ctx=web

This is Bluehost. Support just tried to whitelist some IP which was showing up on Mod security(btw they don’y use mod_evasive) but that didn’t help. So their advise:

Unfortunately, we cannot do much on this. You will have to check this with Cloudflare.

We walk in a circle, it is distressing.

It is not clear what that error message refers to but apparently you seem to attempt to execute a non-existent script. That is a local issue however, not related to Cloudflare.

Hi @sandro,

Could you help me how to proof that this was hosting issue, not CF, besides the facts we have above. I need some strong arguments, otherwise they will skip my request again and redirect to SF. It looks like true because with disabled SF we don’t have such an errors at all!

Thank you all!

There is nothing to prove. You need to analyse the error and find out why it occurs and fix that issue. If it is because of your host and they dont assist you I’d advise to change host. If it isnt you just need to fix the issue.




Asked Bluehost twice today about that situation, first tech guy Akshaya - and this is miracle ! - finally saw server errors and increased memory_limit, I’ve checked again, it seems number of 500 errors decreased but slightly, I’ve asked it again,other support member Anupam advised the next:

I understand your concern. We have increased the memory_limit in your account. The issue is related with DNS cache. Could you access DNS page and purge the cache ? You have set websiteurl nameservers to , so either, you can change back nameservers to us or delete cache from DNS page.

OK, I’ve done that too but nothing changed at all. His answer:

Sounds good! You can check your site after 4 hours and verify if same issue remains or fixed.

Honestly it sounds weird and is unlikely to help … but ok, I’ll wait 4 hours (I’ve also additionally played with Browser Cache Expiration and Development Mode, but this not helped here too).

Will try to find someone else competent inside Bluehost.

Thank you.

That does not make any sense. There is no such thing and nothing to be cleared.

Honestly, I believe - like so many support staff - they just make up random words that sound like a technical explanation. I have to admit I am still not aware what the actual issue is and the host might not be responsible, but with such response I’d be looking for another one anyhow :wink:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.