MTA-STS Multi line record

Im trying to add a Policy TXT Record for our mta-sts. Following instructions from g-suite

Each pair must be on its own line in the text file, as shown in the example below.

version: STSv1
mode: testing
mx: mail.solarmora.com
mx: *.solarmora.net
mx: backupmx.solarmora.com
max_age: 604800

But when i save this out in Cloudflare DNS management page, it condenses this into a single line. I’ve tried multiple suggestions I’ve found online like ; and “” etc to encourage a line break but nothing seems to work and the record, when i check with google admins diagnostic tool, is showing as not correctly configured.

Any assistance is greatly appreciated.

I assume you are talking about 2. Create an MTA-STS policy - Google Workspace Admin Help. This refers to a file, not a TXT record.

1 Like

I use MTA-STS on few of my domains.
Here are the steps:

  1. You have to create a sub-domain mta-sts.yourdomain.com and also add A type DNS record pointed to your IP address for it at your DNS (Cloudflare dashboard).
  2. As @sandro mentioned, you have to create a physical mta-sts.txt file with the needed settings.
  3. You must put the mta-sts.txt file into /public_html/.well-known/ location under that mta-sts.yourdomain.com sub, and it must be accesible over HTTPS.
  4. You have to create an TXT type DNS record _mta-sts.yourdomain.com with value like v=STSv1; id=202026091740 (this long number can be a date or someting).

Later on, you can check and validate if it works using the below tools:

Remember, in case it fails or the DNS record is not recognized, it could take some time to apply the new changes (was a case with me first time, it did not recognized it firstly, but waited for an hour and it worked).

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.