Moving to a new host with domain at cloudflare and ssl from 3rd party

Hi. My domain was transferred to Cloudflare and I am going to move hosting, having an SSL from a 3rd party. What steps should I do on Cloudflare when I change the IP address? Should I pause Cloudflare in order to enable the SSL on the site before I change the IP address at Cloudflare? I don’t want the site to be without a valid SSL and offline for long.
Thanks
Fatima Jesus

For transferring to a new host, hopefully your new host will let you fully configure the domain with SSL before you make the switch. Give that a try first.

If that doesn’t work, you’re going to have to configure your Cloudflare DNS with :grey: for the relevant entries, and I suggest you decrease TTL to 2 Minutes. After five minutes, change the IP addresses for those entries to the new site’s IP.

Once you get your bare site up and running with SSL, switch those Cloudflare DNS entries back to :orange:.

Thanks for your answer. Just to be sure, the «relevant entries» you are talking about would be A record and the www (alias), right?
Regards

Fatima Jesus

Hi
I did contact the hosting and was told that it will not be possible to enable the SSL before changing the IP address. Also, they told me that it can take up to 72 hours for the SSL to be enabled. So I wonder if I can use Cloudflare SSL instead and give up the 3rd party SSL and what settings should I use in this case and if I set the SSL before or after changing the IP address.

Thanks

Your best bet is to follow my instructions for using :grey: for the switchover. There’s no good reason it should take 72 hours for SSL to be enabled on a server. It should be about 5 minutes. Even cPanel’s AutoSSL only takes a few minutes to run through its process.

And, yes, for just moving the website, your “A” records for example.com and www will change. The rest usually don’t change if you’re using a separate host for email.

Hi I did follow the advice and unselect the A record and alias for the site, changed TTL to 2 min but now I can’t add the real domain to my migrated site, it says the domain is already in use. So, this is becoming a nightmare
I called support they tried to add a different domain to the account and worked, can you please tell what can I do to make this work? Getting desperate here.

Thanks

The DNS records for example.com and www need to be updated to whatever the new host wants.

  1. Were both of those “A” records before? Those would have IP addresses.
  2. Are the new records supposed to have IP addresses?

If the answer to both is “Yes,” then you just to edit the “A” record and type in the new IP address for both.

They had IP addresses yes. so, should I enable the orange cloud on both her eon Cloudflare?
thanks

Not yet. Leave them :grey: until your new site is working. If it’s broken, post the domain name so we can take a look.

I went check and only a record had IP address
Thanks

1 Like

I tried again now and was able to connect the domain to the site, probably a cache issue or something. thank you very much for answering.
Regards

1 Like

I had to enable it in order to enable ssl. Otherwise is not possible
An SSL they told me, is onl set with a live site

Regards

1 Like

Hi
The site is showing but misconfigured. Can you please check for me if this is normal? the theme is not showing as it should be.

The URL is: https://atuavidanosastros.com. Before the change of IP address, the site was showing as shown on screenshot (I just changed the image on top)

thanks

2019-06-24.png

You have a host called cdn.atuavidanosastros.com that’s misconfigured.

If it’s on the new server, you’ll need to update that DNS entry as well.

Hi
You were absolutely right. It was fast velocity minify plugin I’ve just disabled it and am going to reinstall again. Thank you very much you are the best!

Regards

1 Like