Moved from Google Domains - Getting this error DNS_PROBE_FINISHED_NXDOMAIN

I transferred my domain from Google Domains yesterday. Followed along with the instructions (don’t think I missed anything), but now I’m getting this error - DNS_PROBE_FINISHED_NXDOMAIN
DNS records are quite simple, I have an A record, pointing to my internal IP, and resolves correctly when I ping it.

My setup…
I run Home Assistant NGINX Reverse Proxy. Incoming requests like would come in on port 80 or 443 and be redirected to the HA NGINX reverse proxy, and then be pointed to the correct internal 192.168 IP or IP and port. Has been working fine till the switch to Cloudflare.

I’m not sure if there are background DNS changes happening or how long that would take. It has been approximately 18 hours since the change. Either way, I feel like I’m overlooking something simple, or missing something right in front of my face.

I’m all ears, and open to suggestions. Also, I’m going to be busy today, so may not respond in a timely fashion, but will certainly follow up by tomorrow. Thank you in advance!!!

Sorry, can’t seem to edit my post.

I have a very glaring error. My domain points to the correct IP, not my internal IP like I wrote above. Sorry…


Well, I think you missed the DNSSEC part. It needs to be disabled at the registrar. Here’s the proper guide:


Thanks for the reply neiljay. I’m pretty sure I disabled that on Google Domains as it was one of the steps, but no way to guarantee. Maybe I didn’t wait long enough? Is there something you are seeing that leads you to believe that, or is it a common missed step, or issue with that error I’m getting?

What is the method to fix this if that was the issue?

Name Server:
Name Server:
DNSSEC: signedDelegation

This is what I see.


Thanks again. Do you feel I’ll need to create a ticket with Cloudflare to resolve this, or are there steps I can take to do this on my own?

There’s a step mentioned. Check the following doc:
Domain Name System Security Extensions (DNSSEC) · Cloudflare Registrar docs.


Sorry, I looked at that, and wasn’t quite sure if I needed to do that or not. I’ve disabled it now, and will patiently wait.


I see the effect. Assume that’s correct!


That has always worked, it is the subdomain and other subdomains that will no longer work. I apologize that I missed stating that in the original post, and most likely led you down the wrong path.

But, looks to me incorrectly configured.

Would you make sure you’ve the correct records set. What I see is: there’s no any record set so far.

1 Like

Other than www, I didn’t have any other CNAME records on the Google Domains, and the A record pointing to my IP. The NGINX Proxy Manager on Home Assistant seemed to handle things just fine. The DNS records were imported from Google to Cloudflare automatically. If Cloudflare requires a CNAME for each subdomain, I can do that, just not sure why, or why it worked over at Google.

I need to check out for the day, but will follow up tomorrow. Have a great day, and thank you so much for the help so far!

There’s no DNS record for this.

Subdomains don’t just leap into existence. If you want a wildcard record, create an A and/or AAAA record with the name * (star) pointing to your IP address, and then any subdomain you don’t otherwise specify will resolve to that IP address.


Well, I guess that is where I was lost. Adding the wildcard seems to have fixed my issues. I most certainly appreciate the help from those that understand this stuff and are willing to help out others.

Cloudflare imported the two DNS records from Google Domains, an A record mapping my domain to my IP, and a CNAME for the www requests. My Nginx Reverse Proxy was working fine before to handle any subdomain I added to NPM.

Apparently Cloudflare must be handling things a bit differently.

Again, thank you all for the assistance.

If it worked before, the name existed on the old system.

When Cloudflare imports records from another DNS provider, it has to guess at what entries might exist. There is technically a way to ask a DNS server for everything in a domain, but everyone shut that off many years ago for security and privacy reasons, so when Cloudflare tries to import your DNS settings, it guesses using a list of the most common subdomain names and so forth. Probably cams isn’t on that list and thus didn’t get imported.

1 Like

I never had the need to add subdomains on my Google Domains. If I wanted to add a new service, I only added it on Nginx Proxy Manager, and it handled it internally, no need to go to Google and add the subdomain name. My Google Domain is gone, so I can’t go back and look, but I’m fairly certain I didn’t have a wildcard record, but I wouldn’t bet on it.

Either way, things seem to be working after adding the wildcard, and I thank you for that.

2 posts were split to a new topic: Cloudflare be the registrar if nameservers point to another server

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.