Moved Access apps from a group to individual apps, now almost nothing loads correctly

I had about 25 apps running on my VPS that I had switched from Nginx Proxy Manager to Cloudflare tunnels. Since I was still pretty new with Cloudflare at the time I was more focused on making them secured than making them look pretty in the app launcher. I had it structured like this:

Application Domain: Apps 1

  • site1.domain to site5.domain

and so on, since there was a max of 5 I had 5 different applications Apps 1,2,3,4 and 5
each with 5 subdomains. This all worked normal and everything loaded correctly and they worked with my OIDC provider.

The issue I have now is I wanted to start using the app launcher more but since I had bundled everything under 1 application I could only access one of the 5 subdomains from the app picker at a time. So I made each web-app it’s own application and policy exactly matching how it used to be, but now the majority the web apps are broken in various ways. The issues are that I have to constantly refresh the page because buttons/pages stop working, or the fonts/images don’t load and it looks bad.

I know the way I had it the first way was probably not correct but I changed almost nothing other than un-grouping them from under one application. I left the cookie settings alone, and exactly matched the policies so I’m curious what I broke. I’ve tried purging all cache and restarting/recreating tunnels.

Any and all help is very much appreciated, thank you!

Just as a test I put everything back into groups and while that seemed to solve the instability issue I still have the image/font loading issue

Ah it was me, I had a worker for security headers set up for the other containers that I had completely forgotten about that didn’t like the new setup. I deleted the worker and set up a new one and it is now working normally.