Move Domain Between CF Accounts

Answer these questions to help the Community help you with Security questions.

What is the domain name?

Have you searched for an answer?
Yes

Please share your search results url:
https://community.cloudflare.com/search?q=move%20domain

When you tested your domain using the Cloudflare Diagnostic Center, what were the results?
not_found_ds_record

Describe the issue you are having:
The domain is in my CF account. I exported the zone file and documented all settings. The zone file and settings were set up in the new account. Then, I went to the registrar and changed name servers from the ones in my CF account to the ones in the new CF account. Within a few minutes, all websites associated with the domain were down. We aren’t using NS records in either account. Should we add those?

What error message or number are you receiving?
ERR_TOO_MANY_REDIRECTS

What steps have you taken to resolve the issue?
Reverted back to the original CF name servers.

Was the site working with SSL prior to adding it to Cloudflare?
Yes

Have you tried from another browser and/or incognito mode?
Yes

I should mention that we are not using DNSEC on this domain, and it’s on the Pro plan in the original CF account.

Greetings,

Thank you for asking.

May I ask if you removed the domain from old CF account after adding it to the new CF account? :thinking:

If so, I’d rather add a domain to the new CF account, change the domain nameservers at domain registrat to the assigned one’s from the new CF account and keep the domain added at the old CF account.
Domain would be removed automatically in next few days or a week on the old CF account.

If you removed your domain from your old CF account, you might end up having some issues with DNS propagation process.

As you encountered an error related to the redirects, may I ask few questions from below?

  1. Before moving to Cloudflare, was your Website working over HTTPS connection?

  2. May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Otherwise, the nameserver propagation time hasn’t finished yet as if you recently changed your domain nameservers, the regular DNS propagation time usually takes up to 24-48 hours to complete.

Have you tried using any of the available online tools for DNS propagation check for your domain name yet? For example:

Nevertheless, upon the nameservers are ok and Cloudflare confirms this change, Cloudflare’s Universal SSL needs to be re-issued at the new CF account.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Great information, thank you for it! As this knows to be the issue when we are changing domain nameservers.

In the meantime, once you’ve changed your domain nameservers at your domain registrar, wait for 24 hours.
Furthermore, you could try to flush the dns for yourdomain.com using below tools for the NS type of the DNS record (selected from the dropdoen menu):

Currently, I can see it’s using ed and iris Cloudflare nameservers.

I did not remove the domain from the old CF account after the name servers were changed at the registrar.

I believe we have found the problem: when the domain was added to the new CF account, CF automatically scanned for DNS records. Those “found” records were mostly pointing CF IP addresses. This was causing the redirect issue.

The new owner is going to delete all those “found” records from the new CF account and import the zone file I exported from the old CF account. We expect that will resolve the issue.

2 Likes

True, so you’d have to export the DNS from old CF account, then remove the automatucally imported DNS records (which would point to the proxied Cloudflare IP instead of the true origin host/server and cause the issue) at new CF account, and easily import them.

Helpful article:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.