MOSS.sh DNS Flow Issue

My domain has been using CloudFlare DNS for months.

I recently setup MOSS Server Control panel on my Hosted Server.
I created a WP Site as a subdomain on the server (example: subdomain1 mydomain com)

I created an A Record in CloudFlare as recommended by MOSS Support so my DNS now looks like:

A domainname com > IP Address > Proxied
A subdomain domainname.com > IP Address > Proxied

However, the subdomain is not browsable unless I remove the Proxy.

What do I need to change so I can have proxied support for the subdomain?

Thanks

Post the actual URLs.

Thanks for the fast response Sandro.

The subdomain is wptest1.swiftpointcloud.com

Here is the support message from MOSS:

From: MOSS.sh Support
Sent: Monday, December 30, 2019 3:57 AM
To: Ty
Subject: Re: Site Not Browsable

Hi Ty,

There seems to be a misconfiguration related to Cloudflare. When trying to browse https://wptest1.swiftpointcloud.com/, it redirects to the same URL:

$ curl -I https://wptest1.swiftpointcloud.com/
HTTP/2 301
date: Mon, 30 Dec 2019 10:54:03 GMT
content-type: text/html
set-cookie: __cfduid=d6400bbcef59509382a373460bce3da4b1577703243; expires=Wed, 29-Jan-20 10:54:03 GMT; path=/; domain=.swiftpointcloud.com; HttpOnly; SameSite=Lax
location: https://wptest1.swiftpointcloud.com/
cf-cache-status: DYNAMIC
expect-ct: max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct
server: cloudflare
cf-ray: 54d37935ba276191-BCN

You might want to disable Cloudflare’s Proxy in order to troubleshoot the issue.

Seems to work for me, however the issue you described typically happens when you have an insecure encryption mode (Flexible). If that is the case, make sure you have a valid certificate on your server and switch to the only secure “Full strict” mode.

Yes as I stated in my previous request.

If I disable ClourFlare Proxy DNS will flow.

I don’t understand what needs to be fixed here and where regarding SSL.

I am using the Let’s Encrypt SSL as provided by MOSS

Post a screenshot of https://dash.cloudflare.com/redirect?zone=ssl-tls

Ok…you meant the SSL Settings in CloudFlare.

It is set to Flexible, which I assume is default as I made no changes to SSL in CloudFlare.
Screenshot:

I did and as I said, switch that to “Full strict” and I would assume the issue should be fixed.

Ok…I have changed to Full Strict as recommended and enabled Proxy.

How long before it should take effect?

If DNS propagation has reached you it should be pretty instantaneous.

Seems to work

sitemeer.com/#https://wptest1.swiftpointcloud.com/

Thanks Sandro this cleared it! Really appreciate your timely response.