Mobile not working after redirection


#1

Hello,
I setup a free ssl plan for my site, and updated the nameservers of my domain.
It sucessfully updated and I can access my site with https on desktop and can see the green lock visible,
However when I try to access it on mobile it doesnt load and browser throws error as “CONNECTION_REFUSED”
Would appreciate if anybody can help.


#2

Are you sure you don’t have any redirects at the site like you title says? That error implies an error at the pure network level where something doesn’t work.

Also: what kind of mobile phone are you using?


#3

Hi!
The redirection occurs to https only. I am using Samsung J2 and Motorola G4.


#4

Would you mind giving me the domain?


#5

https://mscode.com.br


#6

https://www.ssllabs.com/ssltest/analyze.html?d=mscode.com.br&hideResults=on&latest

It gives me no errors for Android 4 and up, you should have at least 6 on the Moto G4.

Could it be the browser? What browser are you using?


#7

I am using chrome and mozilla cleaned with cleaner app


#8

Have you tried cleaning the cache/cookies?


#9

If I turn off redirection it takes a lot of time to connect


#10

Yesterday I purge everything. Desktop is Ok .


#11

Try visiting http://mscode.com.br/cdn-cgi/trace and reporting back the content of the page.

Do use the HTTP, it won’t redirect there.


#12

from desktop chrome:
fl=11f170
h=mscode.com.br
ip=179.153.56.176
ts=1549891612.175
visit_scheme=http
uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36
colo=EWR
http=http/1.1
loc=BR
tls=off
sni=off


#13

I am more interested in the mobile.


#14

ok. I will copy and send it in a minute.


#15

Also do not do the redirect server side. Do it from Cloudflare’s dashboard. Use the Always Use HTTPS toggle in the Crypto settings.

Apache returns a 302 which is not correct for this type of redirect.


#16

Here it is:
fl=11f90
h=mscode.com.br
ip=179.153.56.176
ts=1549891889.018
visit_scheme=http
uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36
colo=EWR
http=http/1.1
loc=BR
tls=off
sni=off


#17

Try doing the same link with HTTPS on mobile.


#18

got this
fl=11f92
h=mscode.com.br
ip=179.153.56.176
ts=1549892219.384
visit_scheme=http
uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36
colo=EWR
http=http/1.1
loc=BR
tls=TLSv1.3
sni=plaintext


#19

There is something wrong there. You can’t have TLS v1.3 and an HTTP scheme.

Try doing the same on the desktop and compare them.

cc @cloonan have you ever seen something like this?

Solved @cloonan.


#20

sorry! it says visi_scheme=https