Mobile device on the Cloudflare's end is redirected to the static subdomain


#1

Hello…

I got a problem after I successfully configured the DNS names in Bluehost that point to Cloudflare and Siteground IP zone.

The website works great in Desktop view but does not work on mobile…it keeps defaulting to https:/static.thetalkbuzz.com even if I type in https://www.thetalkbuzz.com. Then it throws a 404 error we are sorry the page you requested can not be found SiteGround.

This is only occurring on mobile devices.

I’ve reached out to SiteGround and they are unable to resolve the issue, this what they suggested:

I checked and when a request is sent from a mobile device on the Cloudflare’s end is redirected to the above static subdomain:

Code:

donetianpetkov:~ donetian.petkov$ curl -I -A “Mozilla/5.0 (Linux; U; Android 4.0.4 ; en-gb; HTC_Desire_X Build/IMM76D) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30” http://thetalkbuzz.com
HTTP/1.1 302 Moved Temporarily
Date: Sat, 05 Jan 2019 19:50:24 GMT
Connection: keep-alive
Cache-Control: private, max-age=0, no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Expires: Thu, 01 Jan 1970 00:00:01 GMT
Location: http:// static.thetalkbuzz.com /
Server: cloudflare
CF-RAY: 4948794392713ff6-SOF

I researched extensively why would such redirection occur on the Cloudflare’s end but I did not find enough information for the issue.

It best to check this with the Cloudflare’s support team:

https://support.cloudflare.com/hc/en-us

since currently you are using their services directly with them.

Alternatively you may:

  1. Go to your Cloudflare’s account - > DNS zone tab - > create an A record for the www.static.thetalkbuzz.com and point it to the SiteGround’s account IP Address - 109.199.115.137

  2. Click on the orange cloud icons next to both the static.thetalkbuzz.com and the www.static.thetalkbuzz.com

  3. Wait an hour and then install a SSL certificate on the static.thetalkbuzz.com via the cPanel - > Let’s Encrypt

  4. Finally you will need to click the grey cloud icons next to the static and www.static in the DNS zone’s tab.

Please help


#2

Do you have a mobile redirect configured under “Speed”?

It actually does not redirect me to static but to initialcloudflare.


#3

Hello…

Actually I went under the Speed section and tried the Mobile Redirect drop down url’s to thetalkbuzz (A) I get an error, but I can change any other url that’s in the drop down box.


#4

Simply disable it if you dont want to use it, otherwise pick the right host.


#5

I got it set to initialcloudflare, it won’t allow me to set to thetalkbuzz.com (A) record I can see from the drop down but when I try to select it …it defaults to another url record and throw an error invalid sub-domain.


#6

How can I disable the Mobile Direct functionality?


#7

So, are you saying SiteGround doesn’t work with Cloudflare?


#8

SiteGround works with Cloudflare. But it sounds like you want some custom settings.

Can you post a screenshot of that Mobile Redirect section? It should be off until you get the other kinks worked out.


#9

Simply switch it to off.


#10

Hi sdayman,

Attached is the screenshot


#11

Do you want a mobile redirect or not?


#12

No, if I can’t go my website on mobile devices


#13

How can I disable it?


#14

I just explained how :wink:

Off switch


#15

Oh, it’s right there in my face…:sunglasses:


#16

Sort of :slight_smile:

That should fix it, right?


#17

I tried it but it still isn’t bringing up my website…I got a message try clearing your cookies…I am going to clear all caches and get back with you


#18

Redirects are often cached. I’d clear caches and restart the browser or maybe eben try it with a different one. Disabling the redirect should fix the issue.


#19

That did it! it’s back up and running, thank you guys so much :slight_smile:


closed #20

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.