Mixed content error - images


#1

Hello, i have changed over 2 of my word press sites today for ssl

both sites are getting mixed content errors for images

here is errors from whynopadlock

Mixed Content - Errors

Soft Failure An image with an insecure url of “http://topnewsjournal.com/wp-content/uploads/2018/03/lOQdNJ.png” was loaded on line: 1064 of https://www.topnewsjournal.com/.
This URL will need to be updated to use a secure URL for your padlock to return.

Soft Failure An image with an insecure url of “http://topnewsjournal.com/wp-content/uploads/2018/02/1.jpg” was loaded on line: 1074 of https://www.topnewsjournal.com/.
This URL will need to be updated to use a secure URL for your padlock to return.

it seems as both of my sites are getting atleast 1 error from the logo images and then 1 more


#2

Those might be hardcoded somewhere. Here are some ideas:

  1. On Cloudflare’s Crypto page, turn on Always Use HTTPS, and Automatic HTTPS Rewrite. This might be a quick fix.
  2. If you’re running Full or Full (Strict) SSL here and your website Wordpress General Settings is using HTTPS for your URL, you can update the Wordpress database with a search and replace for http://topnewsjournal.com and change it to https://topnewsjournal.com with the following plugin:
    https://wordpress.org/plugins/better-search-replace/

#3

Thank you so much! That did the trick greatly appreciate your time


#4

This topic was automatically closed after 14 days. New replies are no longer allowed.