Missing Emails - no failure notice, no receipt, mx records look good?

mxrecords

#1

Hi All,

I’m desperately seeking out a solution to an email issue I’m experiencing.

Essentially, at present, I’m not getting any emails to [email protected]

My setup is as follows:

A // mydomaindotcom // points to IP1 // Automatic // Grey cloud
A // mail // points to different IP2 // Automatic // Grey cloud
MX // mydomaindotcom // mail handled by server1[.]host[.]tld // 0 // Automatic
MX // mydomaindotcom // mail handled by server2[.]host[.]tld // 10 // Automatic

So, IP2 is provided by the same host company as the MX Records are set to.
IP1 is a second host I’m with.

I’ve been assured by the company I’m trying to get my emails to go to, that all is OK with the MX Records I’ve entered; the server name etc is fine, the server is working correctly etc etc.

I can send an email OUT from mydomain.com without any issues; but I’m not receiving anything. Nothing in the inbox of mydomaindotcom or a “message delivery fail” notice where I’m testing from.

So, somewhere, these emails are just sitting waiting to be told what to do???

Has anyone come across this before? I’m sure I’m missing something obvious, but don’t know what!!

Thanks.


#2

This is hard to troubleshoot as we almost don’t know anything.

Your records look good if they are set up like you described. Cloudflare is diabled so that’s not the issue.

Do you have access to this mailbox via a webmail client? Such errors are often caused by account overquota, cPanel (or what ever) overquota or wrong client configuration (Outlook, Thunderbird)


#3

I’m surprised there is no bounce message… unless I have incorrectly determined the settings.

telnet mx1.4uh.net 25
Trying 89.248.60.6…
Connected to mx1.4uh.net.
Escape character is ‘^]’.
220 se001.4uh.net ESMTP Exim 133235 Wed, 09 May 2018 21:12:04 +0100
ehlo foo.bar
250-se001.4uh.net Hello foo.bar [198.41.128.10]
250-SIZE
250-8BITMIME
250-DSN
250-STARTTLS
250 HELP
mail from:[email protected]
250 OK
rcpt to: [email protected]
550 relay not permitted!
Connection closed by foreign host.

Admittedly I guessed at a user name (but used your domain), but if the error were for a bad user, I would expect a 550 user unknown. 550 relay not permitted indicates to me the MTA in question does not believe it is authoritative for your domain.


#4

SMTP Auth? :thinking:


#5

Inbound MTA… so SMTP Auth shouldn’t be a factor. Unless that isn’t an inbound MTA in which case, the MX record points to the wrong host.


#6

Or I could have just guessed wrong on everything… wouldn’t be the first time. :wink:


#7

I should read things twice… argh

Nah, come on… :wink:


#8

I can login and access the inbox via cPanel webmail (Roundcube, SquirrelMail and Horde) - admittedly, I’ve not attempted accessing via Gmail/Thunderbird/Outlook, that’s something I’ll try now.


#9

Full settings…

My URL - meirdesign.com
Host is 4UH, they’ve told me mail goes to their mail server (mx1.4uh.net or mx2.4uh.net) for scanning etc before going to inbox.
Attempting to email [email protected] as well as a number of others - none are receiving the mail, but all can send from (using webmail - Roundcube).


#10

Yeah I guessed correctly. :slight_smile: I don’t think they have their inbound MTAs configured to accept mail for meirdesign.com. If you test from outside (gmail, etc) I suspect you will see an immediate bounce.

If you open a support ticket with them and paste this is should (to them) be self explanatory (I hope).

telnet mx2.4uh.net 25
Trying 89.248.60.7…
Connected to mx2.4uh.net.
Escape character is ‘^]’.
220 se003.4uh.net ESMTP Exim 133235 Wed, 09 May 2018 21:57:53 +0100
ehlo foo.bar
250-se003.4uh.net Hello foo.bar [198.41.128.10]
250-SIZE
250-8BITMIME
250-DSN
250-STARTTLS
250 HELP
mail from:[email protected]
250 OK
rcpt to:[email protected]
550 relay not permitted!
Connection closed by foreign host.


#11

I’ll C+P it over, thanks.

I’ve been testing from Gmail and no bounce, this is the confusing aspect. I’ve sent 20 emails over the past week and not one has bounced or returned a fail.
I’ve just resent the configuration details for the email account from within cPanel itself, and that’s delivered fine.

I’ve also tested connecting the account in Thunderbird - and again, no email comes through apart from the configuration email.


#12

Bounced immediatly :wink:
:cake:

Final-Recipient: rfc822; [email protected]
Action: failed
Status: 5.0.0
Remote-MTA: dns; mx1.4uh.net. (89.248.60.6, the server for the domain meirdesign.com.)
Diagnostic-Code: smtp; 550 relay not permitted!
Last-Attempt-Date: Wed, 09 May 2018 14:07:21 -0700 (PDT)


#13

Thanks

I’ve sent them the details from previous post, hopefully it’ll be resolved soon.

Didn’t realise wanting to host websites and emails was going to be so difficult…! :thinking:


#14

So, 4UH admitted the routing was incorrect and ‘fixed’ this.

Emails from my other domains (hosted on server 2, different host) aren’t going through still. But I am now receiving emails from Gmail and Outlook… Is this a blacklist on server 2??


#15

If you attach a delivery receipt to your emails is there any data? Ideally you or your host could look at the SMTP logs on server2 to determine what is happening to the messages.


#16

Spoken to the host tonight and I’ve been assured that the mail is leaving server2.

I’m requesting read and delivery status receipts/notices when sending from server2, but nothing is coming back - whether to the domain I’m having issues with or Gmail.


#17

I’ve just tested server2 to server1 using different domains - and the same, it’s not receiving emails from server2.

So server2 must be getting blocked somewhere by server1?? But server2 isn’t on a blacklist, I’ve already checked?


#18

I’ve seen this with Google (Gsuite) where you can login and send but not receive because the domain has expired at the registrar… (but this doesn’t sound like your issue unless your host didn’t check this and/or you have a separate host/registrar and it fell through the cracks).

Use a real time dns tool like DNS Watch to view the settings, i.e. https://www.dnswatch.info/dns/dnslookup?la=en&host=cloudflare.com&type=MX&submit=Resolve and replace with your domain name.


#19

This topic was automatically closed after 14 days. New replies are no longer allowed.