Minimum Version of TLS 1.2 not enforced

Hi,
Under Security Insights I get the: Minimum Version of TLS 1.2 not enforced
It is enforced in: Minimum TLS Version set to 1.2.
And on the origin server 1.1 and 1.0 are not available.

Any idea what I am missing here?