Minecraft SRV Records suddenly not working

It seems to me that something has changed, and a SRV record needs to point to a :grey: hostname. My recommendation would be to create a new hostname, like mc.example.com that’s set to :grey: and have your SRV record point to that new hostname.

1 Like

I have a similar situation with Teamspeak server. Now Proxy doesn’t work. Only set “DNS only” (gray icon). And before, everything worked. On Cloudflare, it looks like some kind of global change is taking place.

Now only HTTP / HTTPS works. Everything else is now unprotected, it seems.

I have same problem…
and only happen with one domain… the others work perfect, only one domain has this issue in my account.

thanks for reply, our problem has been solved after creating a new A record with :grey: status, so we pointing the srv into that new A record.

1 Like

I’ve been using a proxy domain and SRV for almost 6 months or more and now all of the sudden I cannot use SRV with proxy? Before it worked perfectly fine and if I would ping the Minecraft server with https://mcsrvstat.us/ it would show the normal IP etc. Now it just does not work. What did they change? This has to be an issue ? Putting the domain to :grey: doesn’t sound like a solution to me…

1 Like

I don’t know how to edit a reply, I don’t think I can but also it worked fine a few hours ago.
It stopped working maybe 1 or two hours ago.

Hypixel.net Seems to use Cloudflare too but they can use their domain just fine as checked with mcsrvstat which makes this even weirder to me.
Checking Hypixel.net with IPlocation.net shows Cloudflare.

Hypixel probably spends a ton of money on an Enterprise plan so they can use Spectrum for their Minecraft servers.

But what makes it any different from us? It’s also just a srv record, right? What did they change? Why did it work perfectly fine for so many months and even when I made a new server with a new sub domain a month ago? It’s just weird.

Upon reading some replies after finding out my own fix it works fine if I do the following.

So before I would have a subdomain called dmz and it would point to my main domain.
It now doesn’t work.

I made a new subdomain called connect that doesn’t have the proxy
Now dmz points to connect and it works.

I don’t know why or what they changed but meh. After doing this I saw that someone else said this too.

1 Like

Hi there,

This is related to a bug we had last night. It’s already fixed but some zones are still experiencing in issue with it. In this case, we need to force the zone to be rebuild.

For this, please tag me (@tklein) with the name of your zone or alternatively, if you don’t want your zone name to be shared, create a ticket and quote my reply. Whatever Cloudflare Support Engineer is then working on the ticket will then know what to do.

Best,
Tom

4 Likes

@TKlein Hi, my zone must be rebuild too, tscuksy.pl. Thank you

1 Like

Done! (Replied to your ticket as well)

5 Likes

Thank you

Hi, i just create a new ticket to send my zone. because i’m still having this issue

Can you post the ticket #?

1 Like

#2163452

2 Likes

I’ve applied the fix for your zone at this time but please let us know if you continue to run into issues.

3 Likes

thanks for fixing, i’ll contact again after getting some errors

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.