Minecraft SRV Records suddenly not working - New

Hi team.

Recently noticed that my SRV records are not working, nothing has changed from what i can think of for this to now stop. Basically we have SRV records to point from {Server}.brierie.net to {Server}.brierie.access.ly which was working fine but now no one can connect.

Checked the hostname which the SRV points too and can connect fine through that but not through brierie.net.

Anything you can do to help with this, i did see there was something prevously on may that there was an issue with this?

Thank you

1 Like

brierie.net doesn’t resolve. It looks like you’re missing a DNS record.

Thanks for responding, i have pointed this to the IP address we use for the servers, but even with this pointed it still doesnt seem to be working for the SRV record.

Below is one of the SRV records :

and the other the A record for brierie.net pointing to our IP:

So ive made sure that lobby.brierie.access.ly is pointed to the correct IP which it is. I have then looked at cloudflares settings for the A record which is brierie.net pointing to the same IP. I have checked the SRV record which is lobby for the name which points to lobby.brierie.access.ly

Even when i ping on my computer it says the below:

C:\Users\brier>ping brierie.net

Pinging brierie.net [] with 32 bytes of data:
Reply from bytes=32 time=19ms TTL=52
Reply from bytes=32 time=18ms TTL=52
Reply from bytes=32 time=18ms TTL=52
Reply from bytes=32 time=18ms TTL=52

Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 18ms, Maximum = 19ms, Average = 18ms

C:\Users\brier>ping lobby.brierie.access.ly

Pinging lobby.brierie.access.ly [] with 32 bytes of data:
Reply from bytes=32 time=18ms TTL=52
Reply from bytes=32 time=18ms TTL=52
Reply from bytes=32 time=18ms TTL=52
Reply from bytes=32 time=17ms TTL=52

Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 17ms, Maximum = 18ms, Average = 17ms

C:\Users\brier>ping lobby.brierie.net
Ping request could not find host lobby.brierie.net. Please check the name and try again.

Not sure what i am doing wrong here, basically we used to have it set up where people would use the hostname lobby.brierie.net when using this it then ported through the other hostname lobby.brierie.access.ly and worked fine but now its not working at all.

There’s most likely no CNAME or “A” record called “lobby” in your DNS page here. I do believe that’s required, in addition to the SRV record.

From what i understand is that i dont want an A record or CName Record for brierie.net as i want it to be ported to brierie.access.ly

Basically The players still get to use the original hostname but actually connect through the new one which is brierie.access.ly

Here is what i have as an example:

This was supposedly an issue in the last ticket about this issue with minecraft and srv records.

Is there a way to resolve this going forward as i really need this to work for players to be able to connect with our hold original hostname.

Hi there, This is related to a bug we had last night. It’s already fixed but some zones are still experiencing in issue with it. In this case, we need to force the zone to be rebuild. For this, please tag me (@tklein) with the name of your zone or alternatively, if you don’t want your zone name to…

Hi @brierie,

That bug related to direct connect records added automatically to allow connections to work, when an SRV record pointed to a proxied hostname.

I don’t think that applies in your case, as yours seem to point to external hostnames.


HI @domjh Yes the SRV points to an external hostname which is brierie.access.ly this is something we have done for a few years now with no issues. but now it doesnt seem to be working. What i can confirm is that if i just direct connect using brierie.access.ly that will work so it seems to be an issue with the SRV/Cloudflare not too sure what i can do to then resolve this issue.

I’m not really too sure what the issue could be. Cloudflare doesn’t proxy non HTTP traffic and the record is not pointing to a Cloudflare hostname.

I see the record just fine:

$ dig SRV _minecraft._tcp.lobby.brierie.net +short
0 0 25565 lobby.brierie.access.ly.

Do you have any indication from the Minecraft client as to what the issue is? The record looks OK, unless I’m missing something.


HI @domjh

I brought up the client and before that also flushed my DNS chache but when trying to connect i get this:

Connecting to lobby.brierie.net, 25565
Couldn’t connect to server
java.net.UnknownHostException: lobby.brierie.net
at java.net.InetAddress.getAllByName0(InetAddress.java:1280)
at java.net.InetAddress.getAllByName(InetAddress.java:1192)
at java.net.InetAddress.getAllByName(InetAddress.java:1126)
at java.net.InetAddress.getByName(InetAddress.java:1076)
at net.minecraft.client.multiplayer.GuiConnecting$1.run(GuiConnecting.java:67)

Just your standard unknown host error.

also just as a test i can connect fine through lobby.brierie.access.ly with no problems so i know the Hostname is working correctly.


Just went on a radom DNS/SRV checker and it seems it does not see the SRV record at all:

I’m pretty sure it shouldn’t be needed, but can you try adding an A record for lobby pointing to the Minecraft server IP?

I’m not sure what the error formatting is in the MC client, but it appears to be trying to connect to port 25565 on your lobby hostname, rather than the one specified in the SRV target.


That doesn’t seem to be checking _minecraft._tcp.

1 Like

I can give it a try but the only issue with that i think is then it will go direct to the A record and not use the SRV which is what i am wanting it to do basically, im not all too well versed in DNS systems XD

@domjh so when i do that it connects direct to the A record bypassing the SRV basically what i need is it to route through the SRV record.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.