Minecraft Server UnknownHostException Error

I opened a server for minecraft. Previously normal But after a while, I get an error “java.net.UnknownHostException: first.throwable.in” which is a dns that I don’t know.

I’ve run the command nslookup first.throwable.in and it outputs “Server: one.one.one.one

I don’t know what to do next I tried changing the server to a different computer with a different internet service provider. is the same

Google cloud Vm is the same.

1 Like

Has anyone encountered this issue or is there a solution?

I am fairly certain that


is not a domain but the name of an exception. The problem probably lies deeper than what you see in the log.

What I’ve tried to solve initially but didn’t work is

  • change server and internet service provider (This I think works but it doesn’t)
  • use google cloud vm to open server (not works)
  • delete and reinstall java (not works)
  • moved to run on linux server (not works)
  • Turn off the firewall (not works)
  • set dns ipv4 to cloudflare (not works)
    I don’t know what to do anymore.

Generally these errors are caused by malware in your plugins, you can try downloading the plugins again from spigotmc/bukkit etc and checking if the checksum still matches up. The “Updater” class is often used to hide malicious code and will spread to other plugins so all .jar files in your server will need to be deleted and downloaded again from a trusted source.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.