Minecraft server requires domain followed by port


I am setting up a Minecraft server and set up Cloudflare, but when I try and connect via the subdomain I

made for connections (play.jabpark.us) it instead requires me to connect via using the port after it


Any way to fix this?

I would recommend checking out this guide for help using Minecraft with Cloudflare:

So i tried redoing it using that tutorial and im still at the same area and it gives me this error code when trying to join it

I believe it is because its still trying to use the 25565 port by default, i need a fix for this

I only see an A record for play.jabpark.us. You need an SRV record similar to the one posted in the tutorial

I do have one, i dont know why it isint showing up, that does make sense why its forcing me to use the port but i dont know how to fix this

What do your full records look like? Here is an example with my domain. Yours should look similar apart from the IP of the play record.


Hey i actually found the fix to this, i had to add my a record after the srv record was added and it worked perfectly fine!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.