Migration between to Cloudflare accounts

I attempted to move my domain that is manged by another Cloudflare account to another CF account (just DNS managed, not the domain its self).

I added the domain to my new account, imported DNS settings. I then updated the NS on the domain registrar. CF then told be it was active. I then generated new Origin Certificate to place on my server. I ensured by TLS setting were set to Full (strict).

When visiting the site again the cert was not valid. It was showing the Origin Cert, which should not be shown in the browser. Every help page I could find said the DNS entry must not be proxied, but it was. I even tried unproxing and waiting a few minutes and then proxying it again. I also removed and added the entries again.

I tried regenerating the cert a few times and placing it on the server(s) (thought this might be an issue due to terminating TLS on a load balancer for one server). Still the same issue.

I then added a new DNS entry pointing to a new IP. This never resolved thus could not get there.

All this made me think the domain is still using the old account and not the new one. I then migrated it back and everything worked as expected.

What have a done wrong here?


It sounds that you had an issue with the Universal SSL certificate issuance, and the encryption mode that you’ve selected.

Please, check here: Move a domain between Cloudflare accounts · Cloudflare Fundamentals docs

Be aware that SSL/TLS certificates associated with your previous Cloudflare account will not be transferred to your new account. If your site requires an SSL/TLS certificate prior to domain transfer, refer to Minimize downtime.

Take Care!


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.