Microsoft Remote Desktop Gateway via Proxied?

Problem: Cannot get remote access via Microsoft Remote Desktop Gateway working when DNS entry for the RDG server is in Proxied mode. RD Connection client errors with “The remote resource cannot be reached.”

  • When DNS entry is NOT in Proxied mode, connectivity works fine.
  • Verified the DNS on the client is updating to the proxy IP prior to attempting to connect.
  • The error msg often indicates a certificate issue. I have tried SSL mode in Full, Flexible, and Off, with no difference.

That makes me think it’s not a supported port:

Microsoft RDG uses HTTPS over 443. That’s all that’s required on on our firewall. So, its unclear why the proxy mode in Cloudflare does not work.

Check the Firewall Events Log to see if that request was blocked, and why.

No Firewall events recorded.

Looks like it might need Spectrum to make it work. But…of course…I go into Spectrum and all I see for options are “Minecraft” and “SSH” applications. WTF?

Turns out I would need to spend $180 more per mo to go from Pro to Business level just so I can have access to the RDP application choice.

That’s a crappy way to create perceived value.