Microsoft Edge Issues

Hey all. We have figured out how to redirect our non-www URL correctly on all browsers. BUT, whenever a user types the non-www url into a microsoft edge browser they are directed to GoDaddy… has anyone experienced this bug? What is the solution?

Thanks!

It actually sounds like either a cache or dns propagation issue.

Cam you share the name of the domain?

Some ideas, let us know if they are helpful:

  1. Ensure correct DNS settings in GoDaddy - you must have A record in DNS settings pointing to your website’s IP address for both ‘www’ and non-‘www’ versions. Those records should be proxied :orange:, not :grey:.
  2. Clear the DNS cache on Microsoft Edge. The users can press Ctrl + Shift + Delete then select ‘Cookies and other site data’, then click ‘Clear’.
  3. It will also be helpful to use https://www.whatsmydns.net/ to check whether your DNS settings have propagated.

Beyond that, details are helpful.

1 Like

This is so helpful. Thank you so much for responding so quickly. The domain for reference is learnwithdanielle dot com

Both the HTTP and HTTPS versions of learnwithdanielle.com load the GoDaddy parking page for me. This suggests to me that your Cloudflare redirect is not being employed. Unless you plan on sending vistors to a GoDaddy hosted site at that naked domain in the future, I would delete any current A and AAAA records for learnwithdanielle.com. I would also remove whatever Cloudflare redirect you currently have in place.

Once that is done, I would create one AAAA for @ (which will appear as learnwithdanielle.com once saved). Use the special address of 100:: in that AAAA record. That will ensure that your traffic never accidentally winds up routed somewhere you hadn’t intended. Then you can add a redirect rule like the one found in example 1 in the following guide.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.