Messed up DNS entries

Dear community,

I’ll start by saying that I am not a technical person and have left someone set up the entries for me a certain point and he didn’t do a great job it seems.

My problem is that whenever I try to remove/edit the entries no matter the type, mx, cname, txt, they always reappear after <24 hours.

I tried removing the site and re added it but didn’t get lucky.

To give you a bit of context. I am hosting a WP site on my Synology, and also use google workspace for mailing solutions.
With the current setup these are the problems:
a) I have added the mx entries from google, they work fine but for 24 hours.
b) I have removed the a entry and added a cname since my ip is dynamic. Again this works fine but for 24 hours till the settings get reset.

Can someone please shed light on why this happening and how do I fix it?

Many thanks,

Cata

This is probably set up with a DDNS script. This script does always (daily) re-point the IP of some domains/subdomains to its own IP to work properly.

You can solve your problem on three ways:

  1. deactivate the script from that NAS
  2. kill the API key the script uses (if you cant find the script)
  3. use other subdomains for what you want to do now

If you have not set this up I would recommend contacting the person and tell him what you want to do now and ask/pay for him adjusting it to what you need now

Hi Martin,

Thanks for the swift reply:)

I cannot get a hold of that person but would try to do it on my own this time. Everything that was configured in Synology was done through clicks, no code, scripts, etc. This leads me to point 2. Where do I find this API key and how do I remove it?

Thanks,

Cata

Normaly you can find that token (API Tokens) here:
https://dash.cloudflare.com/profile/api-tokens

I don’t have any API token >

Can you then please check at:
https://dash.cloudflare.com/?to=/:account/audit-log

What changes your DNS Settings? This is the log there it should be logged when something changes something. You then can see what have changed this

I am looking at it Martin but don’t understand much… The first entry for today appears to be auto login. The rec del, set and add have been added by me.

image

Actually this screenshot does not show the user. You now should see which user added/edited the DNS settings.

Just click on one entry with “Rec set” and it shows you details. These details will show on which way (API or Dashboard) the entry was edited/set.
They also show from which IP actually things git changed.

P.S.: dont hardcode your copyrights :wink:

Here is an extended entry… the A entry which got automatically created.

The IP 35.153.49.42 belongs to (SOURCE) Amazon. Do you have anything set up there which is re-setting the A-Record.
Also the Screenshot clearly states:

Interface: API

So this change used a APIToken to change things
Maybe this script even uses your “Global API Key” which gives it access to ALL functions without limits. So you may wanna change this key to a new key

Actually this again does not show which USER initiated this. Check if the user have done this changes is your user or a different user you hay have invited to manage your CloudFlare Account

Nothing at all related to my website.
I will try changing this and see how it works:)

I have changed it Martin, I should see if it worked in <24 hours from now.

Thank you so much for your inputs.

PS: Just curious, what is wrong in hardcoding my copyrights ?

They dont change as they are hardcoded and in some years your site looks like noone maintained it due to old copyrights.
As you use WordPress you can have a read HERE how to implement shortcodes for “year”

Or install a Plugin which provides this function ==> https://de.wordpress.org/plugins/jonradio-current-year-and-copyright-shortcodes/

Thanks for the tip Martin, I’ll look into it once I sort the pressing matter for the DNS settings. It’s driving me nuts.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.