Meshcentral Agents can no longer connect using tunnel

I have been using meshcetral through cloudflare tunnels for a long time now. Recently it stopped working. The only port required is 443.
The agents can see the clients but cannot connect to them anymore.
Turns out I am not the only one with this issue. On the Meshcentral github, there has been quite some discussion. From what I can tell the issue is because of something cloudflare has changed recently and not with meshcentral itself.

If anyone has any insights please let us know


the issue also effects people using the Proxied DNS with NO Tunnels


Helllllllloooo Cloudflare , this is a issue that needs to be fixed. I was going to spend money on pro but after this why should I even waste my money?

I’m having the same problem. I thought it was DNS, so I started messing around and was able to connect to any client internally, but I can’t connect to any external client.

It has started to work 50% of the time. It’s very strange behavior. Surely another recent change from cloudflare has made this work, but why would it only work inconsistently?

I’m having the same issue! What has changed on Cloudflare’s end to cause this?

Exactly the same problems here. Went through a stage of working 50% of the time a few weeks ago. Would have to continually connect and disconnect until it worked. Now it usually connects but I get black screen. Mouse inputs are being sent but no diplay. Same story with terminal and files. Connects but no data.

Same problem here, when DNS proxy is activated, i can connect to the meshcentral agents connected from internet through Cloudflare proxy, but i cant receive any image (as i troubleshooted meshcentral implements WebSockets and receives every image frame as a binary payload from WS which isn’t received)

Hi, i just checked with the cloudflare support and they are consulting if someone have tested with a previous version of meshcentral (previous to 1.1.8 version)?


Hi, just tested with version 1.1.5 and its the same blackscreen.

I have this issue as well. Any eta of a fix? Sadly I may have to give up mesh central and remote access.

The only way it can be made to work currently is by turning off the proxy and using DNS only. However, this is not a safe option and many of us want to enjoy all services from cloudflare.

It has been confirmed that it’s due to something that changed on cloudflare’s side and that it’s not something that is solved by upgrading to the pro subscription, see the git-hub link in the initial post

Any update on a resolution for this issue?

Have you heard back from cloudflare support?

Tested this with version 1.1.21, black screen on desktop connect.

Good night everyone, after lots of tears and blood I finally manage to get working Meshcentral through Cloudflare Tunnel or Cloudflare Zero Trust…

Yesterday I was doing some tests, and finally understood what did I have to do to make it work! Is very simple, look, Meshcentral have a way to function verifying the origin certificate and the client certificate…

The origin certificate is the certificate installed on the Meshcentral Server and the client certificate is the certificate that we get on the browser, so now, what do we have to do to solve this? Simple, the config.json file has a parameter called certUrl…

You have to point the IP of the proxy from Cloudflare! When you add you subdomain on Cloudflare Zero Trust, this subdomain gets a IP address, you will setup the certUrl parameter with this IP address, e g. “certUrl”: “”, the parameter is shown exactly as I described. You will need to do some changes in the config.json file besides certUrl parameter…

I promise that later I’ll post my config file here! I hope that help you guys that’s is getting trouble to put Meshcentral to work with Cloudflare… Ps: the same config works with Meshcentral of Tactical RMM.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.